Page MenuHomePhabricator

Run script to fix inconsistent titles for Greek and Chinese Wikipedias
Closed, ResolvedPublic

Description

Hello folks at Wikimedia,
as outlined in T215028 and T215030 there are some instances of inconsistent titles, that can be fixed by running namespaceDupes.php on the Greek and Chinese versions.

Can somebody run that script? 😏
Enrico

Event Timeline

Restricted Application added subscribers: Cosine02, Aklapper. · View Herald TranscriptJan 31 2019, 5:59 PM
Aklapper renamed this task from Inconsistent titles to Run script to fix inconsistent titles for Greek and Chinese Wikipedias.Jan 31 2019, 9:07 PM
Reedy closed this task as Resolved.Feb 9 2019, 11:11 PM
Reedy claimed this task.
Reedy added a subscriber: Reedy.
reedy@mwmaint1002:~$ mwscript namespaceDupes.php --wiki=elwiki --fix --add-suffix=/FIXME
id=251531 ns=0 dbk=ΒΠ:3RR -> Βικιπαίδεια:3RR/FIXME (alternate)
id=400257 ns=0 dbk=ΒΠ:5 -> Βικιπαίδεια:5/FIXME (alternate)
id=36511 ns=0 dbk=ΒΠ:5Θ -> Βικιπαίδεια:5Θ/FIXME (alternate)
id=447614 ns=0 dbk=ΒΠ:5Π -> Βικιπαίδεια:5Π/FIXME (alternate)
id=35684 ns=0 dbk=ΒΠ:5Σ -> Βικιπαίδεια:5Σ/FIXME (alternate)
id=262865 ns=0 dbk=ΒΠ:AWB -> Βικιπαίδεια:AWB/FIXME (alternate)
id=376101 ns=0 dbk=ΒΠ:BBC -> Βικιπαίδεια:BBC/FIXME (alternate)
id=12837 ns=0 dbk=ΒΠ:COOL -> Βικιπαίδεια:COOL/FIXME (alternate)
id=28376 ns=0 dbk=ΒΠ:GFDL -> Βικιπαίδεια:GFDL/FIXME (alternate)
id=461689 ns=0 dbk=ΒΠ:IP -> Βικιπαίδεια:IP/FIXME (alternate)
id=108774 ns=0 dbk=ΒΠ:SPAM -> Βικιπαίδεια:SPAM/FIXME (alternate)
id=23399 ns=0 dbk=ΒΠ:Stub -> Βικιπαίδεια:Stub/FIXME (alternate)
id=447609 ns=0 dbk=ΒΠ:Α -> Βικιπαίδεια:Α/FIXME (alternate)
id=233094 ns=0 dbk=ΒΠ:ΑΓΝΟΗΣΤΕ -> Βικιπαίδεια:ΑΓΝΟΗΣΤΕ/FIXME (alternate)
id=73521 ns=0 dbk=ΒΠ:ΑΔΕΙΑ -> Βικιπαίδεια:ΑΔΕΙΑ/FIXME (alternate)
id=140740 ns=0 dbk=ΒΠ:ΑΘΛ -> Βικιπαίδεια:ΑΘΛ/FIXME (alternate)
id=115578 ns=0 dbk=ΒΠ:ΑΤΤ -> Βικιπαίδεια:ΑΤΤ/FIXME (alternate)
id=447608 ns=0 dbk=ΒΠ:Αγορά -> Βικιπαίδεια:Αγορά/FIXME (alternate)
id=143205 ns=0 dbk=ΒΠ:ΒΙΒΛΙΑ -> Βικιπαίδεια:ΒΙΒΛΙΑ/FIXME (alternate)
id=44618 ns=0 dbk=ΒΠ:ΒΙΟ -> Βικιπαίδεια:ΒΙΟ/FIXME (alternate)
id=115283 ns=0 dbk=ΒΠ:ΓΔ -> Βικιπαίδεια:ΓΔ/FIXME (alternate)
id=225132 ns=0 dbk=ΒΠ:ΓΟΑ -> Βικιπαίδεια:ΓΟΑ/FIXME (alternate)
id=377050 ns=0 dbk=ΒΠ:ΔΕ -> Βικιπαίδεια:ΔΕ/FIXME (alternate)
id=226282 ns=0 dbk=ΒΠ:Ε -> Βικιπαίδεια:Ε/FIXME (alternate)
id=94479 ns=0 dbk=ΒΠ:ΕΕ -> Βικιπαίδεια:ΕΕ/FIXME (alternate)
id=253099 ns=0 dbk=ΒΠ:ΕΠ -> Βικιπαίδεια:ΕΠ/FIXME (alternate)
id=73487 ns=0 dbk=ΒΠ:ΕΡΕΥΝΑ -> Βικιπαίδεια:ΕΡΕΥΝΑ/FIXME (alternate)
id=140721 ns=0 dbk=ΒΠ:ΕΣ -> Βικιπαίδεια:ΕΣ/FIXME (alternate)
id=250909 ns=0 dbk=ΒΠ:Εγκυκλοπαιδικότητα -> Βικιπαίδεια:Εγκυκλοπαιδικότητα/FIXME (alternate)
id=295903 ns=0 dbk=ΒΠ:Εξωτερικοί_σύνδεσμοι -> Βικιπαίδεια:Εξωτερικοί_σύνδεσμοι/FIXME (alternate)
id=457284 ns=0 dbk=ΒΠ:Επέκταση -> Βικιπαίδεια:Επέκταση/FIXME (alternate)
id=250996 ns=0 dbk=ΒΠ:Επαληθευσιμότητα -> Βικιπαίδεια:Επαληθευσιμότητα/FIXME (alternate)
id=277447 ns=0 dbk=ΒΠ:ΖΩ -> Βικιπαίδεια:ΖΩ/FIXME (alternate)
id=365927 ns=0 dbk=ΒΠ:ΖΩΑ -> Βικιπαίδεια:ΖΩΑ/FIXME (alternate)
id=285628 ns=0 dbk=ΒΠ:ΗΠΑ -> Βικιπαίδεια:ΗΠΑ/FIXME (alternate)
id=17445 ns=0 dbk=ΒΠ:Κ3Ε -> Βικιπαίδεια:Κ3Ε/FIXME (alternate)
id=460638 ns=0 dbk=ΒΠ:ΚΑΛ -> Βικιπαίδεια:ΚΑΛ/FIXME (alternate)
id=73509 ns=0 dbk=ΒΠ:ΚΑΤ -> Βικιπαίδεια:ΚΑΤ/FIXME (alternate)
id=54419 ns=0 dbk=ΒΠ:ΚΡΑ -> Βικιπαίδεια:ΚΡΑ/FIXME (alternate)
id=463062 ns=0 dbk=ΒΠ:ΛΕΞΙΚΟ -> Βικιπαίδεια:ΛΕΞΙΚΟ/FIXME (alternate)
id=299536 ns=0 dbk=ΒΠ:ΟΔΗΓΟΣ -> Βικιπαίδεια:ΟΔΗΓΟΣ/FIXME (alternate)
id=33802 ns=0 dbk=ΒΠ:ΟΥΔ -> Βικιπαίδεια:ΟΥΔ/FIXME (alternate)
id=15629 ns=0 dbk=ΒΠ:ΟΧΙ -> Βικιπαίδεια:ΟΧΙ/FIXME (alternate)
id=73513 ns=0 dbk=ΒΠ:ΠΗΓΕΣ -> Βικιπαίδεια:ΠΗΓΕΣ/FIXME (alternate)
id=73512 ns=0 dbk=ΒΠ:ΠΗΓΗ -> Βικιπαίδεια:ΠΗΓΗ/FIXME (alternate)
id=77413 ns=0 dbk=ΒΠ:ΠΙΝ -> Βικιπαίδεια:ΠΙΝ/FIXME (alternate)
id=155516 ns=0 dbk=ΒΠ:ΠΛ -> Βικιπαίδεια:ΠΛ/FIXME (alternate)
id=91469 ns=0 dbk=ΒΠ:ΠΟΔ -> Βικιπαίδεια:ΠΟΔ/FIXME (alternate)
id=115284 ns=0 dbk=ΒΠ:ΠΠΔ -> Βικιπαίδεια:ΠΠΔ/FIXME (alternate)
id=286925 ns=0 dbk=ΒΠ:Πολιτική -> Βικιπαίδεια:Πολιτική/FIXME (alternate)
id=90500 ns=0 dbk=ΒΠ:Σ -> Βικιπαίδεια:Σ/FIXME (alternate)
id=109909 ns=0 dbk=ΒΠ:ΣΓ -> Βικιπαίδεια:ΣΓ/FIXME (alternate)
id=73488 ns=0 dbk=ΒΠ:ΣΓΔ -> Βικιπαίδεια:ΣΓΔ/FIXME (alternate)
id=73477 ns=0 dbk=ΒΠ:ΣΔ -> Βικιπαίδεια:ΣΔ/FIXME (alternate)
id=141582 ns=0 dbk=ΒΠ:ΣΕ -> Βικιπαίδεια:ΣΕ/FIXME (alternate)
id=287687 ns=0 dbk=ΒΠ:ΣΕΔ -> Βικιπαίδεια:ΣΕΔ/FIXME (alternate)
id=460639 ns=0 dbk=ΒΠ:ΣΠΟΡ -> Βικιπαίδεια:ΣΠΟΡ/FIXME (alternate)
id=324197 ns=0 dbk=ΒΠ:ΣΥΝΘ -> Βικιπαίδεια:ΣΥΝΘ/FIXME (alternate)
id=324198 ns=0 dbk=ΒΠ:ΣΥΝΘΕΣΗ -> Βικιπαίδεια:ΣΥΝΘΕΣΗ/FIXME (alternate)
id=143206 ns=0 dbk=ΒΠ:ΣΧΡΗ -> Βικιπαίδεια:ΣΧΡΗ/FIXME (alternate)
id=74722 ns=0 dbk=ΒΠ:ΤΕΧ -> Βικιπαίδεια:ΤΕΧ/FIXME (alternate)
id=164335 ns=0 dbk=ΒΠ:ΦΥΕ -> Βικιπαίδεια:ΦΥΕ/FIXME (alternate)
id=136629 ns=0 dbk=ΒΠ:ΦΧ -> Βικιπαίδεια:ΦΧ/FIXME (alternate)
id=73511 ns=0 dbk=ΒΠ:ΧΕΙΡ -> Βικιπαίδεια:ΧΕΙΡ/FIXME (alternate)
64 pages to fix, 64 were resolvable.

pagelinks from=261444 ns=0 dbk=ΒΠ:Εγκυκλοπαιδικότητα -> Βικιπαίδεια:Εγκυκλοπαιδικότητα
pagelinks from=447726 ns=0 dbk=ΒΠ:Εγκυκλοπαιδικότητα -> Βικιπαίδεια:Εγκυκλοπαιδικότητα
pagelinks from=341062 ns=0 dbk=ΒΠ:Επαληθευσιμότητα -> Βικιπαίδεια:Επαληθευσιμότητα
pagelinks from=341082 ns=0 dbk=ΒΠ:Επαληθευσιμότητα -> Βικιπαίδεια:Επαληθευσιμότητα
pagelinks from=447726 ns=0 dbk=ΒΠ:Επαληθευσιμότητα -> Βικιπαίδεια:Επαληθευσιμότητα
5 links to fix, 5 were resolvable.

Looks good!
reedy@mwmaint1002:~$ mwscript namespaceDupes.php --wiki=zhwiki --fix --add-suffix=/FIXME
id=4488106 ns=0 dbk=Talk:沙溪兴教寺 -> Talk:沙溪兴教寺/FIXME (alternate)
id=4775712 ns=0 dbk=User_talk:Yuriy_kosygin -> User_talk:Yuriy_kosygin/FIXME (alternate)
id=4488064 ns=0 dbk=Wikipedia:知识问答 -> Wikipedia:知识问答/FIXME (alternate)
3 pages to fix, 3 were resolvable.

pagelinks from=935984 ns=0 dbk=WP:沙盒 -> Wikipedia:沙盒
1 links to fix, 1 were resolvable.

Looks good!

Thanks Reedy! Apparently there are more wikis: T109238. Should we setup a regular check to detect this issue?

Shizhao moved this task from Backlog to Closed on the Chinese-Sites board.Feb 11 2019, 9:31 AM
Reedy added a comment.Feb 11 2019, 6:48 PM

Thanks Reedy! Apparently there are more wikis: T109238. Should we setup a regular check to detect this issue?

It'd certainly be nice, but I'm not sure how we'd go about trying to handle it.

I suspect there's a lot of wikis with inaccessible pages that they don't know/care about. And with NS aliases et al being added and removed, and the occasional MW issue, this is going to continue

I'm not sure how we'd go about trying to handle it

So to be clear, I am not suggesting you to do that, I (we dbas) had in mind some regular reporting setup that do "production testing", specifically for mediawiki data consistency. We have T207253 in the works, and I was wondering if this would be interesting as an additional check (among others).

With the last sentence, I am not sure if you would be happy or consider very low priority compared to other potential checks. I am ok both ways, it is just not clear what you mean.

Reedy added a comment.Feb 11 2019, 7:41 PM

I'm not sure how we'd go about trying to handle it

So to be clear, I am not suggesting you to do that, I (we dbas) had in mind some regular reporting setup that do "production testing", specifically for mediawiki data consistency. We have T207253 in the works, and I was wondering if this would be interesting as an additional check (among others).
With the last sentence, I am not sure if you would be happy or consider very low priority compared to other potential checks. I am ok both ways, it is just not clear what you mean.

So, namespaceDupes is usually fixing inconsistencies that are usually caused by MW config changes and the alike. I don't think it is a good check of more general data consistency

For example, in NS 0 (because the prefix doesn't exist) you create WP:Foo. You also create page Foo in NS 4 (Wikipedia). Both pages are accessible for the moment.

Then someone decides WP should be an alias NS for NS 4. WP:Foo now becomes inaccessible, because MW can't differentiate between Wikipedia:Foo and WP:Foo. Namespace dupes (if told to add a suffix/prefix) will move WP:Foo to NS 4 to {$prefix}Foo{$suffix}

Similar examples are WP:Foo being created in NS 0, and then WP being created as a proper namespace. MW's title parsing will look for the Page foo in the WP namespace, not a page called WP:Foo in the NS 0. namespaceDupes will move page WP:Foo in NS 0 to NS $whatever to a page called Foo