Page MenuHomePhabricator

hat-web-tool: delete & projects both broken
Closed, ResolvedPublic

Description

Per title. We should investigate whether to fix them or take them down.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 4 2019, 7:25 PM

Is the source code available?

It is a tool that we host but whose code is hosted in another tools project IIRC. I'll take a look at the repos and get back to you with an answer. Regards.

Is the source code available?

They're in the hat-web-tool folder at rTSTW tool-stewardbots (code development happens at Gerrit though, Phab is just a mirror). Best regards.

It looks like "projects" works fine now: https://tools.wmflabs.org/stewardbots/hat-web-tool/projects.php

I should check 'delete' as well.

Change 518187 had a related patch set uploaded (by MusikAnimal; owner: MusikAnimal):
[labs/tools/stewardbots@master] Update queries for action and comment migration

https://gerrit.wikimedia.org/r/518187

Change 518187 merged by jenkins-bot:
[labs/tools/stewardbots@master] Update queries for actor and comment migration

https://gerrit.wikimedia.org/r/518187

@MusikAnimal was kind enough to upload a patch and I've merged it. However the tool is not working. I must also note that using webservice (kubernetes) with php7.2 delivered a blank page on the tool too, so I had to restart it using the legacy php5.6. Maybe the tool also needs to be upgraded to use the latest PHP versions...

@MarcoAurelio It actually works for me, it is just super slow.

@MarcoAurelio It actually works for me, it is just super slow.

True. I had to enter a number in the searchbox in order to get it to work though (I used 1). IIRC previously if you didn't entered any number, some results were displayed, right?

I'm not sure, I know Erwin's tool worked that way but I'm not sure if mine did.

Okay, so with both tools working maybe we can close this task and create another to make the tool support new versions of PHP?

Okay, so with both tools working maybe we can close this task and create another to make the tool support new versions of PHP?

I got bored and worked on PHP 7.2 migration, too. If you create a ticket I can submit what I have.

Okay, so with both tools working maybe we can close this task and create another to make the tool support new versions of PHP?

I got bored and worked on PHP 7.2 migration, too. If you create a ticket I can submit what I have.

You're awesome, @MusikAnimal - I'll do.

MarcoAurelio closed this task as Resolved.Jun 25 2019, 1:25 PM
MarcoAurelio assigned this task to MusikAnimal.