Page MenuHomePhabricator

[BUG] Time period on my event keeps getting switched
Closed, ResolvedPublic2 Story Points

Description

  • Go to Event Metrics and create a new event whose time period begins earlier that day and ends in the near future. (here is mine, for reference.)
  • Add participants to the event.
  • Calculate metrics
  • Add a foreign wiki like fr.wiki (I don't know if that matters)
  • Calculate metrics
  • Go back to Settings

Expected result: the time period remains as you set it
Actual result: the time period switches to the future (in my case, from 2/5 at 9AM to 2/5 at 5pm). This happened more than once.

See labeled screenshots below, which document the second time I did this. The time when I did all this was about 11 am.

Event Timeline

jmatazzoni triaged this task as Normal priority.Feb 5 2019, 7:02 PM
jmatazzoni created this task.
jmatazzoni moved this task from Backlog to To be estimated on the Event Metrics board.

Looking at the screenshots, my guess is that timezone conversion isn't happening the way it should. Might just be only a frontend problem.
You added time as 9am which shows up as 5pm afterwards. 9am PST is 5pm UTC. I'm pretty sure dates are all stored in UTC in the backend.

Yep, I think we're just not passing the right value to the datepicker. The timestamps you see on the Event Summary page are correct, it is just showing the wrong times when editing an event.

Niharika renamed this task from Bug: Time period on my event keeps getting switched to [BUG] Time period on my event keeps getting switched.Feb 5 2019, 9:16 PM
jmatazzoni set the point value for this task to 2.Feb 7 2019, 12:20 AM
Samwilson claimed this task.Feb 7 2019, 3:21 AM
Samwilson moved this task from Ready to In Development on the Community-Tech-Sprint board.

That looks easier than we thought.

The tests for this PR are now passing. Ready for re-review.

Followed Joe's reproduction steps to make a new event and did not see the bug.

I couldn't reproduce with preexisting events either.

I also notice that Joe's event from the Description now shows the correct date in the date picker on the Settings page.

I checked that I could change the date/time for an event with the date picker and that this was reflected in the event summary page and on subsequent visits to the Settings page.

jmatazzoni closed this task as Resolved.Feb 18 2019, 11:06 PM
jmatazzoni moved this task from Product sign-off to Q3 2018-19 on the Community-Tech-Sprint board.