Page MenuHomePhabricator

Oversighters can no longer see suppressed contributions past a certain date when using the offender parameter
Closed, ResolvedPublic

Description

Not exactly sure when this started, but oversighters cannot see suppressed edits upon clicking the "suppressed user contributions" link. It seems from some minimal testing that recent suppressions appear, but older ones do not; I'm not sure where the cutoff is. As an example, I suppressed a single edit in my sandbox just now, but while that appears none of my previous suppressed edits appear; see https://en.wikipedia.org/w/index.php?title=Special:Log/suppress&offender=Amorymeltzer

Alternatively, compare https://en.wikipedia.org/wiki/Special:Log?type=suppress&offender=217.61.20.119 (old, doesn't not working) with https://en.wikipedia.org/w/index.php?title=Special:Log/suppress&offender=173.244.134.162 (new, working).

It seems the error has to do with the offender parameter. For an example, searching via target works fine https://en.wikipedia.org/wiki/Special:Log?type=suppresspage=User%3AAmorymeltzer but searching revision author with the user who made those edits fails https://en.wikipedia.org/w/index.php?title=Special:Log/suppress&offender=204.45.110.42 Potentially relatedly, the OOUI inputWidget for Revision Author (i.e. the offender parameter) dropdown (div#mw-input-offender) does not autofill like the other menus.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptWed, Feb 6, 9:21 PM
Amorymeltzer triaged this task as Unbreak Now! priority.Wed, Feb 6, 9:26 PM
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptWed, Feb 6, 9:26 PM
Amorymeltzer renamed this task from Oversighters can no longer see suppressed contributions past a certain date to Oversighters can no longer see suppressed contributions past a certain date when using the offender parameter.Wed, Feb 6, 9:42 PM
Amorymeltzer updated the task description. (Show Details)
Risker added a subscriber: Risker.Wed, Feb 6, 9:44 PM
DoRD added a subscriber: DoRD.Wed, Feb 6, 9:54 PM
JJMC89 added a subscriber: JJMC89.Thu, Feb 7, 2:46 AM
Anomie claimed this task.Thu, Feb 7, 2:44 PM
Anomie added a subscriber: Anomie.

Caused by the actor migration script run. Changing the actor migration from "read-both/write-old/new" to "write-both/read-old/new" required changing the migration script to not blank the old content, and making that fix for the log_search table was missed. I'm working on repopulating the old content now.

Mentioned in SAL (#wikimedia-operations) [2019-02-07T15:07:15Z] <anomie@mwmaint1002> Fixing log_search after migrateActors.php on test wikis and mediawikiwiki for T215464. This may cause lag in codfw.

Mentioned in SAL (#wikimedia-operations) [2019-02-07T15:16:18Z] <anomie@mwmaint1002> Fixing log_search after migrateActors.php on section 1 wikis for T215464. This may cause lag in codfw.

Mentioned in SAL (#wikimedia-operations) [2019-02-07T15:16:21Z] <anomie@mwmaint1002> Fixing log_search after migrateActors.php on section 2 wikis for T215464. This may cause lag in codfw.

Mentioned in SAL (#wikimedia-operations) [2019-02-07T15:16:23Z] <anomie@mwmaint1002> Fixing log_search after migrateActors.php on remaining section 3 wikis for T215464. This may cause lag in codfw.

Mentioned in SAL (#wikimedia-operations) [2019-02-07T15:16:25Z] <anomie@mwmaint1002> Fixing log_search after migrateActors.php on section 4 wikis for T215464. This may cause lag in codfw.

Mentioned in SAL (#wikimedia-operations) [2019-02-07T15:16:27Z] <anomie@mwmaint1002> Fixing log_search after migrateActors.php on section 5 wikis for T215464. This may cause lag in codfw.

Mentioned in SAL (#wikimedia-operations) [2019-02-07T15:16:30Z] <anomie@mwmaint1002> Fixing log_search after migrateActors.php on section 6 wikis for T215464. This may cause lag in codfw.

Mentioned in SAL (#wikimedia-operations) [2019-02-07T15:16:32Z] <anomie@mwmaint1002> Fixing log_search after migrateActors.php on section 7 wikis for T215464. This may cause lag in codfw.

Mentioned in SAL (#wikimedia-operations) [2019-02-07T15:16:34Z] <anomie@mwmaint1002> Fixing log_search after migrateActors.php on section 8 wikis for T215464. This may cause lag in codfw.

Mentioned in SAL (#wikimedia-operations) [2019-02-07T15:16:36Z] <anomie@mwmaint1002> Fixing log_search after migrateActors.php on wikitech for T215464. This may cause lag in codfw.

Anomie lowered the priority of this task from Unbreak Now! to Low.Thu, Feb 7, 3:34 PM

This should now be fixed on all Wikimedia wikis.

Not closing the bug yet as the maintenance script should also be patched to not do this (even though it's too late for Wikimedia wikis).

Change 488951 had a related patch set uploaded (by Anomie; owner: Anomie):
[mediawiki/core@master] migrateActors.php: Don't delete log_search rows when migrating

https://gerrit.wikimedia.org/r/488951

Anomie added a comment.Thu, Feb 7, 4:31 PM

For the record, repopulating the deleted rows can be as simple as running the following MySQL database query:

INSERT IGNORE INTO log_search (ls_field, ls_value, ls_log_id) SELECT
   CASE WHEN actor_user IS NULL THEN 'target_author_ip' ELSE 'target_author_id' END,
   COALESCE( actor_user, actor_name ),
   ls_log_id
 FROM log_search JOIN actor ON (ls_value = actor_id) WHERE ls_field = 'target_author_actor';

Change 488951 merged by jenkins-bot:
[mediawiki/core@master] MigrateActors: Don't delete log_search rows when migrating

https://gerrit.wikimedia.org/r/488951

Anomie closed this task as Resolved.Tue, Feb 19, 9:52 PM