Page MenuHomePhabricator

Regression: Nested references do not work
Closed, ResolvedPublic

Description

Caught by browser test. This is blocking merges in Minerva. Nested references are no longer behaving as they should

QA steps

-A drawer appears:


-Click the reference inside the drawer.

  • Expected: reference drawer updates
  • actual: browser navigates to reference (#cite_note-1)

QA Results

StatusDetails
✅ PassedT215536#4946266

Event Timeline

Jdlrobson created this task.Feb 7 2019, 5:26 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 7 2019, 5:26 PM
Jdlrobson triaged this task as High priority.Feb 7 2019, 5:27 PM
Jdlrobson added a subscriber: Niedzielski.EditedFeb 7 2019, 10:26 PM

It looks like this got fixed by @Niedzielski's patch I08c0faaba50037566bef22dd401b3480081ebe60
I am seeing the issue before this patch but not after.

It was broken by @Niedzielski's patch Ic193e97b4cd6f72d226bd9768e904bdec168ba39
Luckily that didn't make the train so no follow ups or SWATs required as it's not included in the current deploy branch! (phew)

(

@Jdlrobson, sorry for the hassle but I'm glad it's fixed

ovasileva removed Jdlrobson as the assignee of this task.Feb 8 2019, 10:00 AM
ovasileva added a subscriber: ovasileva.

Seems like this should first go through QA

Jdlrobson added a comment.EditedFeb 8 2019, 6:35 PM

@Edtadros this one does have an automated browser test that is now passing and previously wasn't.
https://integration.wikimedia.org/ci/view/Reading-Web/job/selenium-MinervaNeue/832/ (note the failures in here appear to be for another regression that ill open a ticket for for today)

Is that enough?
Super curious to hear your thoughts on the line between relying on manual and automated QA!

Test Result

Status: ✅ PASS
OS: macOS Mojave
Browser: Chrome DevTools Device Emulator (iPhone X)

Test Artifact(s):
When the reference link [1] in the drawer that opened from [note 1] was clicked, the reference in the drawer updated to the nested reference as seen in the screenshot below:

Edtadros updated the task description. (Show Details)Feb 12 2019, 4:39 AM
ovasileva closed this task as Resolved.Feb 12 2019, 8:51 AM

looks good, thanks @Edtadros!