Page MenuHomePhabricator

QA edit tags for moderation actions
Closed, ResolvedPublic

Description

Background

In T212959: Create AMC edit tag we confirmed that the new AMC tag exists for edits. To confirm that the tag exists for moderation actions as well (defined in T213461 ), we will have to QA separately in production.

QA criteria

Confirm that when the following actions are executed in production from an AMC opted-in account, they are tagged with both advanced mobile edit and mobile web edit in the corresponding public log:

  • (enwiki-specific, may need to be postponed: reviewing new pages (cf. Special:NewPagesFeed)
  • NB: We're not covering patrolling actions at this point, although this might change later.

It would be great if the QA report could include links to resulting logs events. (Narrowing down the corresponding log to your own actions, by entering your user name under "Performer", should be sufficient.) This will make it easier for @Tbayer to check the result on the database side as well.

(Other reverts, i.e. those that are not made via either undo or rollback, should already be covered by the QA for normal edits, and thus do not need to be tested separately.)

QA Results

ACStatusDetails
1T215597#5166315 - Will QA in task T219895
2T215597#5166315 - Will QA in task T219895
3T215597#5166315
4T215597#5166315
5T215597#5166315
6T215597#5166315
7T215597#5166315 - Functionality not available in testwiki

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 8 2019, 11:17 AM
ovasileva triaged this task as Normal priority.Feb 8 2019, 11:17 AM
ovasileva moved this task from To Triage to Triaged but Future on the Readers-Web-Backlog board.
ovasileva closed subtask T212959: Create AMC edit tag as Resolved.
Tbayer updated the task description. (Show Details)Feb 25 2019, 10:27 PM

@ovasileva I need more detail on with regards to what the validations will be for each of the QA Criteria listed in the description. It might be obvious, but I'm not certain what "tagged accordingly"

@Tbayer Can you help define "tagged accordingly" in the QA Criteria. I don't want to make any assumptions as I recall this is a very important task.

Tbayer updated the task description. (Show Details)Apr 4 2019, 2:39 AM

@Edtadros Sure, thanks for checking! I have edited the task description in that regard, let me know if this is helpful.
I also took the opportunity to rewrite rest somewhat, adding more explanatory links and nuance.

ovasileva reassigned this task from ovasileva to Edtadros.Apr 10 2019, 5:07 PM
phuedx added a subscriber: phuedx.EditedApr 26 2019, 10:29 AM

AIUI this task has been blocked on a request for privileges on some (all?) of the Wikipedias. The request has stalled, insofar as it hasn't been rejected nor has it been resolved, since giving a test account such privileges on production wikis will be viewed with suspicion by the community and may result in unintended outcomes.

I discussed this with @Edtadros recently and suggested that we acknowledge our limits and test what we can on testwiki and the BC.

I discussed this with @Edtadros recently and suggested that we acknowledge our limits and test what we can on testwiki and the BC.

sounds good!

Edtadros added a comment.EditedMay 8 2019, 8:03 AM

Test Result:Production

Status: ✅ PASS (with AC1, AC2, and AC7 deferred)
OS: iOS
Browser: Chrome browser on (iPhone XS Max)

Test Artifact(s):

⬜ AC1: undo: tags should show up in user contributions
This was unavailable. @ovasileva to add this to the signoff criteria for the history page.

⬜ AC2: rollback: tags should show up in user contributions
This was unavailable. @ovasileva to add this to the signoff criteria for the history page.

✅ AC3: blocking (Special:Block): block log
https://test.m.wikipedia.org/w/index.php?title=Special:Log&type=block&user=EdTest001&page=&wpdate=&tagfilter=&subtype=

✅ AC4: unblocking (Special:Unblock): block log
https://test.m.wikipedia.org/wiki/Special:Log?type=block&user=EdTest001&page=&wpdate=&tagfilter=&subtype=unblock

✅ AC5: deleting (example): deletion log
https://test.m.wikipedia.org/wiki/Special:Log?type=delete&user=EdTest001&page=&wpdate=&tagfilter=

✅ AC6: moving pages (example): move log
https://test.m.wikipedia.org/wiki/Special:Log?type=move&user=EdTest001&page=&wpdate=&tagfilter=&subtype=AC7: thanks (analogous to T215477#5039143)

⬜ AC7: Approving pending changes: review log
This functionality isn't available on test.wiki.

For the three wikis (eswiki, idwiki, arwiki) I searched the logs for any entries tagged "advanced mobile edit" for AC1, AC2, and AC7. I didn't find any.

Edtadros updated the task description. (Show Details)May 8 2019, 8:07 AM
ovasileva closed this task as Resolved.

Looks like we're all done here! Added AC1 and AC2 to T219895: Style the history page for AMC users. Thanks for all your hard work on this @Edtadros!

phuedx added a comment.May 8 2019, 1:41 PM

🎉🎉🎉