Page MenuHomePhabricator

Lago di Garda doesn't exist on Wikimedia maps
Closed, ResolvedPublic

Description

See https://maps.wikimedia.org/#11/45.6191/10.6430, the problem is the same for all layers as far as I see.

Event Timeline

Marsupium created this task.Feb 8 2019, 6:12 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 8 2019, 6:12 PM
jcrespo added a subscriber: jcrespo.Feb 8 2019, 6:48 PM

Most likely it was accidentally "broken" on the underlying OSM data? It seems to be ok now there, so maybe it will fix itself with time, when the data updates.

Geometry nor relevant tags for Lago di Garda OSM object (r8569) doesn't seem to have changed lately. Earlier in relation to another object @MSantos mentioned that there might be a problem with OSM replication system. Lago di Garda polygon doesn't seem to be available via geoshape service either.

Gehel added a subscriber: Gehel.Feb 12 2019, 4:08 PM

It still looks broken to me. This needs some investigation to understand what is happening.

LGoto triaged this task as Normal priority.Feb 13 2019, 4:35 PM

Reported again via OTRS Ticket#2019021810005137. After mentioning the problem in #wikimedia-tech on IRC, most were able to reproduce the issue while another was not (see logs).

MSantos claimed this task.Mar 25 2019, 3:05 PM
Pikne added a comment.May 23 2019, 7:39 AM

So, a couple of days ago someone edited the OSM object and now water appears again as tiles get updated. Geometry nor styles related tags weren't changed.

It seems that as with my route examples in T218097 making the latest version of an OSM object part of different "good" changeset is a workaround to include the object in Wikimedia database. Why some changesets are "bad" (edited objects get ignored by Wikimedia) still remains a question.

Marsupium added a comment.EditedJun 16 2019, 7:48 PM

Now in contrast, there is a huge invented water body in Sughd, Tajikistan, apparently bordered by rivers. See https://maps.wikimedia.org/#9/39.2312/68.6810.
Screenshot:

Pikne added a comment.Jun 17 2019, 6:23 AM

Now in contrast, there is a huge invented water body in Sughd, Tajikistan, apparently bordered by rivers. See https://maps.wikimedia.org/#9/39.2312/68.6810.

That was apparently a tagging error on OSM relation 3280692. I now removed the errorenous waterway tag from it, so hopefully this will be fixed eventually when map tiles get updated.

So, a couple of days ago someone edited the OSM object and now water appears again as tiles get updated. Geometry nor styles related tags weren't changed.

Interestingly now all water is gone again on Wikimedia tiles. I wonder if it relates to activity in T224395?

Change 522072 had a related patch set uploaded (by MSantos; owner: MSantos):
[operations/puppet@production] Disable replicate and admin cron in eqiad

https://gerrit.wikimedia.org/r/522072

Change 522072 merged by Gehel:
[operations/puppet@production] Disable replicate and admin cron in eqiad

https://gerrit.wikimedia.org/r/522072

MSantos closed this task as Resolved.Jul 18 2019, 3:07 PM

It's now fixed, we still need to finish T218097 though. Please reopen or fill another ticket if you see anything related.

Thanks for the patience.

Marsupium reopened this task as Open.EditedSun, Sep 29, 3:42 PM

Not this happens for Lake Maggiore, see https://maps.wikimedia.org/#10/45.9000/8.5776.

MSantos closed this task as Resolved.Mon, Oct 7, 1:46 PM

@Marsupium, since Lake Di Garda is not an issue and Lake Maggiore is reported here T233188, I'm closing this task and moving the discussion to the appropriate phab ticket. Thanks for taking a look at it.