Page MenuHomePhabricator

Change file pages to display content in tabs, with captions and the wikitext block in the first and statements in the second
Closed, ResolvedPublic

Description

Acceptance criteria:

  • File pages show the content split into sections for non-JS users
  • File pages show the content split into tabs for JS users, without a FOUC
  • First tab, labelled "File information", shows the captions block display/editor and the wikitext block
  • Second tab, labelled "Structured data", shows the statements block display/editor – https://wikimedia.invisionapp.com/share/NJOIMI9D6SX#/screens/330580747
  • No H1 heading any more

The file interaction block and the "what is metadata" information panel in the illustration are both out of scope.

Related Objects

StatusAssignedTask
Declineddchen
OpenNone
OpenNone
DuplicateNone
OpenNone
ResolvedAbit
OpenNone
DuplicateNone
OpenNone
OpenNone
OpenNone
OpenNone
ResolvedCparle
OpenNone
ResolvedPDrouin-WMF
ResolvedCparle
ResolvedJdforrester-WMF
ResolvedCparle

Event Timeline

Jdforrester-WMF triaged this task as High priority.
Ramsey-WMF moved this task from Untriaged to Next up on the Multimedia board.Mar 8 2019, 4:53 PM
Yann added a subscriber: Yann.Mar 8 2019, 9:26 PM

Change 493432 had a related patch set uploaded (by Matthias Mullie; owner: Cparle):
[mediawiki/extensions/WikibaseMediaInfo@master] Tabify file information and structured data

https://gerrit.wikimedia.org/r/493432

Right now, history/file usage/EXIF metadata placement is outside the tab container, which means it shows regardless of what tab a user is on.

Per convos with @Cparle and @Ramsey-WMF, I think it should be brought inside the tab container under file information -- otherwise it looks like it's showing up twice because it appears under structured data, when it's not structured data.

Once we have more statements launched, there could be a community discussion about additional tabs and what goes where, but for now, it makes sense to keep all information users see now on File Page on the File information tab, and depicts/other statements on the second tab as it helps maintain the status quo.

Change 493432 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Tabify file information and structured data

https://gerrit.wikimedia.org/r/493432

Cormac did all the work here. :-)

This is fixed for sites with statements (Depicts) live. Leaving to Ramsey to decide how to represent that in Phabricator. :-)

Cormac did all the work here. :-)

Matthias too!

ok on test-commons

Ramsey-WMF closed this task as Resolved.Apr 24 2019, 12:24 AM

Working as intended on production