Page MenuHomePhabricator

The included enhanced RecentChanges has a different collapsible toggle button
Closed, ResolvedPublicBug

Description

Steps to reproduce:

  • Load Special:RecentChanges?enhanced=1 --> The enhanced changes list has triangles as collapsible toggle buttons. A click on a triangle expands the collapsed part of the changes list.
  • Create a page with the content:
{{Special:RecentChanges|enhanced=1}}
  • Load this page. --> The enhanced changes list has triangles as collapsible toggle buttons. But a click on the triangle do nothing. There are additional buttons [Expand]. A click on these buttons expands the collapsed part of the changes list.

Expected behavior: The includes recent changes should look and behave like the normal recent changes.

Event Timeline

Fomafix created this task.Feb 10 2019, 8:12 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptFeb 10 2019, 8:12 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 489485 had a related patch set uploaded (by Fomafix; owner: Fomafix):
[mediawiki/core@master] EnhancedChangesListGroup.mustache: Remove spaces inside of <td>

https://gerrit.wikimedia.org/r/489485

@Krinkle wrote on Gerrit:

I think the problem here isn't the spaces. The problem is that this is not meant to be interpreted as wikitext. Internal tranclusion is capable of outputting HTML directly, which afaik is what this page should do as well. It's not meant to go through wikitext again.

Change 489485 merged by jenkins-bot:
[mediawiki/core@master] ChangesList: Remove spaces from <td> in EnhancedChangesListGroup.mustache

https://gerrit.wikimedia.org/r/489485

Fomafix updated the task description. (Show Details)Feb 12 2019, 1:21 PM

https://gerrit.wikimedia.org/r/489485 fixes the collapsing toggle button.

There are still some different alignments because of the <p> elements that get inserted in <td> elements with line breaks when including.

Change 490580 had a related patch set uploaded (by Fomafix; owner: Fomafix):
[mediawiki/core@master] ChangesList: Comment out newlines in EnhancedChangesListGroup.mustache

https://gerrit.wikimedia.org/r/490580

Fomafix changed the subtype of this task from "Task" to "Bug Report".Feb 28 2019, 7:43 AM

Change 490580 had a related patch set uploaded (by Fomafix; owner: Fomafix):
[mediawiki/core@master] ChangesList: Comment out newlines in EnhancedChangesListGroup.mustache

https://gerrit.wikimedia.org/r/490580

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptWed, Apr 3, 4:54 AM

Change 490580 merged by jenkins-bot:
[mediawiki/core@master] ChangesList: Comment out newlines in EnhancedChangesListGroup.mustache

https://gerrit.wikimedia.org/r/490580

Fomafix closed this task as Resolved.Thu, Apr 4, 5:56 AM
Fomafix removed a project: Patch-For-Review.