Page MenuHomePhabricator

Update repos that are using mediawiki/mediawiki-codesniffer v24.0.0 but allow PHP < 5.6.99
Open, NormalPublic

Description

It was noticed, and fixed in https://gerrit.wikimedia.org/r/#/c/php-session-serializer/+/489948/ that php-session-serializer had been updated to use mediawiki/mediawiki-codesniffer v24.0.0, but still allowed PHP < 5.6.99 (specifically "php": ">=5.5.9", in this case), and was still testing on older PHP version on travis

I'm not sure if this is widerspread, but we should tidy up any other libraries where this is also a problem

Event Timeline

Reedy created this task.Feb 12 2019, 5:04 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 12 2019, 5:04 AM
Reedy renamed this task from Update libraries that are using mediawiki/mediawiki-codesniffer v24.0.0 but allow PHP < 5.6.99 to Update repos that are using mediawiki/mediawiki-codesniffer v24.0.0 but allow PHP < 5.6.99.Feb 12 2019, 5:07 AM
Reedy updated the task description. (Show Details)
Reedy triaged this task as Normal priority.