Page MenuHomePhabricator

Merge conflict error broken on mobile
Closed, ResolvedPublic

Description

NOTE: This task was created post-merge to define this work as a subtask of T202374

The error handling for the mobile wikitext editor does not produce the correct error messages when an edit conflict occurs. Instead it produces a generic error message "Error, edit was not saved".

Steps to Reproduce

(i.e. create an edit conflict)

  1. Open a mobile test page, such as betawiki Math in two tabs
  2. In both tabs, open the mobile editor
  3. In one tab, save an edit
  4. In the other tab, try to save the edit.

Expected Results

  • The first edit should save successfully (which it does).
  • The second edit should produce an edit conflict (which it does), and warn the user with the mobile-frontend-editor-error-conflict message. (i.e. "Error, another user has edited this page."), which it doesn't.

Actual Results

  • The first edit saves successfully
  • The second edit produces the generic HTTP error message instead of the error-conflict message.
  • NOTE: currently, NO message is visible because the toast-message fail to render properly in the overlay, after T197499, a red error box should be seen.

Environments Observed

  • Local, beta-wiki

AC

  • The correct error message is shown when an error conflict occurs on mobile.

Fix: https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/MobileFrontend/+/455895/

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 12 2019, 10:40 AM
Jdrewniak closed this task as Resolved.Feb 12 2019, 10:40 AM
Jdrewniak triaged this task as Normal priority.