Page MenuHomePhabricator

Specific image displayed with 180° rotation in Wikipedia iOS App
Closed, ResolvedPublic

Description

Event Timeline

Thyj created this task.Feb 14 2019, 4:41 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 14 2019, 4:41 AM
Restricted Application added a project: Wikipedia-iOS-App-Backlog. · View Herald TranscriptFeb 14 2019, 6:43 AM
Aklapper renamed this task from The image can not be displayed normally in Wikipedia iOS App to Specific image displayed with 180° rotation in Wikipedia iOS App.Feb 17 2019, 5:02 AM
JMinor triaged this task as Low priority.
JMinor moved this task from Needs Triage to Bug Backlog on the Wikipedia-iOS-App-Backlog board.
Mhurd added a subscriber: Mhurd.Feb 28 2019, 8:45 PM

Repro steps:

  • enwiki > 75 Livingston Street
  • tap lead image
  • it flips!

The issue is the EXIF orientation contained in the images. By default, the img tag (and the iOS gallery) don't rotate the image based on the EXIF orientation. This codepen illustrates the issue, and has a CSS fix (image-orientation: from-image;) that works in Firefox, but not Chrome or Safari: https://codepen.io/anon/pen/ywKxKB

ABorbaWMF added a subscriber: ABorbaWMF.

Looks good to me on 6.2.1 (1592)

JMinor added a subscriber: JMinor.Apr 9 2019, 5:52 PM

@Shizhao @Thyj This should be fixed in the most recent release (6.2.1) published on Apr 8

JMinor closed this task as Resolved.Apr 9 2019, 5:52 PM
Shizhao moved this task from Backlog to Closed on the Chinese-Sites board.Apr 10 2019, 3:14 AM