Page MenuHomePhabricator

[BUG] SVG Translate does not display all labels in the file
Closed, ResolvedPublicBUG REPORT

Description

Current behavior:

  1. Go to https://tools.wmflabs.org/svgtranslate/File:Anatomy_of_the_Human_Ear.svg

  1. Compare with image on Commons
  1. Notice the word "Stapes" (near the top) is missing from the rendering in SVG Translate and is also not displayed as an input label.

Expected behavior:

All labels from the original file are preserved in the SVG-translate render. This ticket is similar to T215836: [BUG] Word missing in rendered image.

Event Timeline

Niharika triaged this task as Normal priority.Feb 15 2019, 9:02 PM
Niharika created this task.
Restricted Application added a project: Community-Tech. · View Herald TranscriptFeb 15 2019, 9:02 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

@MaxSem thinks this is bug is because of the same problem as in T215580: [BUG] Labels for image keep jumping outside the image frame. Holding off on assessing this until that one is complete.

dom_walden closed this task as Resolved.May 21 2019, 12:31 PM
dom_walden claimed this task.
dom_walden added a subscriber: dom_walden.

I cannot reproduce this. It looks very similar to what was fixed in T216283, as "Stapes" is not inside a <tspan>.

Restricted Application changed the subtype of this task from "Task" to "Bug Report". · View Herald TranscriptMay 21 2019, 12:31 PM