Page MenuHomePhabricator

Adding a caption add file unintentionally to watchlist
Closed, ResolvedPublic

Description

Adding a caption add file unintentionally to watchlist

Steps to reproduce:

  1. Enable, if not already done, the option "Add pages I create and files I upload to my watchlist" in your preferences (watchlist section)
  2. Load a file without captions
  3. Add a caption in a language of your choice
  4. Result: File was added to your watchlist even that you have not created the file/file page

Expected result: No change of the watchlist status.

My interpretation of this behaviour: Creating a first caption is handled as page creation. And this is wrong.

Event Timeline

Raymond created this task.Feb 17 2019, 6:00 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 17 2019, 6:00 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Probably a bug in the slot handling code in EditPage (such as it is), but we'd need to check this out at our end first.

Restricted Application added a project: Wikidata. · View Herald TranscriptFeb 19 2019, 12:02 PM

This will be due to the adding of a caption creating the mediainfo entity

in Wikibase, MediawikiEditEntity::getWatchDefault does not take into account slots creation vs page creation when using the "watchcreations" user pref.
It probably should now?

Yann added a subscriber: Yann.Apr 28 2019, 5:36 PM
Ramsey-WMF assigned this task to Cparle.May 2 2019, 12:14 AM
Ramsey-WMF triaged this task as Medium priority.
Ramsey-WMF added a subscriber: Ramsey-WMF.

following up on this: problem is still present as of today (may or may not have been fixed previously)

Restricted Application added a project: Multimedia. · View Herald TranscriptMay 2 2019, 12:14 AM
Ramsey-WMF moved this task from Untriaged to Next up on the Multimedia board.May 2 2019, 1:01 AM
Roy17 added a subscriber: Roy17.May 15 2019, 6:24 PM

Adding depicts statements also adds pages to my watchlist even though I've switched that off for pages I edit in settings.

seav added a subscriber: seav.Jun 13 2019, 7:40 PM
Cparle removed Cparle as the assignee of this task.Jun 17 2019, 9:16 AM
Cparle added a subscriber: Cparle.

At least for statements, this issue is still present – I just got a bunch of new watchlist entries from some AC/DC edits.

Roy17 awarded a token.Dec 16 2019, 5:33 PM
Ainali added a subscriber: Ainali.Feb 14 2020, 8:28 PM
Restricted Application added a project: Structured-Data-Backlog. · View Herald TranscriptMar 16 2020, 3:38 PM

Any progress on it? It is really annoying to remove watchlist entries again after using AC/DC

Change 602777 had a related patch set uploaded (by Lucas Werkmeister; owner: Lucas Werkmeister):
[mediawiki/extensions/Wikibase@master] Fix watching new entities on existing pages

https://gerrit.wikimedia.org/r/602777

Change 602778 had a related patch set uploaded (by Lucas Werkmeister; owner: Lucas Werkmeister):
[mediawiki/extensions/WikibaseMediaInfo@master] Add integration test for watchlist behavior

https://gerrit.wikimedia.org/r/602778

LucasWerkmeister claimed this task.EditedJun 5 2020, 10:26 PM

Alright, I think I’ve found a fix for this. Adding the Wikidata campsite board for review, because the fix is actually in Wikibase, not WikibaseMediaInfo. (That said, review from the WikibaseMediaInfo people would help as well, especially for the integration test.)

Change 602777 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Fix watching new entities on existing pages

https://gerrit.wikimedia.org/r/602777

Change 602778 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Add integration test for watchlist behavior

https://gerrit.wikimedia.org/r/602778

Lydia_Pintscher closed this task as Resolved.Jun 16 2020, 4:27 PM
Lydia_Pintscher added a subscriber: Lydia_Pintscher.

Tested it and it works for me now \o/