Page MenuHomePhabricator

JSTOR is blocking citoid IPs
Closed, ResolvedPublic

Description

I have filed this report earlier on dewiki, to no avail.

Visual editor (and, of course, wikitext 2017) fail to create references from JSTOR. I run the latest Firefox on macOS 10.13.6.

  • Start editing in VE/WT-2017
  • Put the cursor where a new reference should be placed
  • Click on the cite button and insert, e.g., https://www.jstor.org/stable/43203215
  • Nothing happens. VE says, "Wir konnten für dich keinen Beleg erstellen. Du kannst einen manuell durch Verwendung der obigen Registerkarte „Manuell“ erstellen."
  • Browser Konsole says:
Error while detaching the browsing context target front: Connection closed, pending request to server1.conn1.parentProcessTarget1, type detach failed

Request stack:
request@resource://devtools/shared/protocol.js:1384:14
generateRequestMethods/</frontProto[name]@resource://devtools/shared/protocol.js:1545:14
BrowsingContextTargetFront<.detach<@resource://devtools/shared/fronts/targets/browsing-context.js:84:24
destroy/this._destroyer<@resource://devtools/client/framework/target.js:800:17
destroy@resource://devtools/client/framework/target.js:775:24
eventSource/proto.emit@resource://devtools/shared/client/event-source.js:128:9
onClosed@resource://devtools/shared/client/debugger-client.js:900:5
close@resource://devtools/shared/transport/local-transport.js:154:9
close@resource://devtools/shared/transport/local-transport.js:150:7
close@resource://devtools/shared/transport/local-transport.js:150:7
cleanup@resource://devtools/shared/client/debugger-client.js:300:9
detachClients@resource://devtools/shared/client/debugger-client.js:325:9
safeOnResponse@resource://devtools/shared/client/debugger-client.js:519:14
listenerJson@resource://devtools/shared/client/debugger-client.js:542:26
emit@resource://devtools/shared/event-emitter.js:178:15
emit@resource://devtools/shared/event-emitter.js:255:5
emitReply@resource://devtools/shared/client/debugger-client.js:823:31
callFunctionWithAsyncStack@resource://devtools/shared/platform/stack.js:61:10
onPacket@resource://devtools/shared/client/debugger-client.js:825:9
send/<@resource://devtools/shared/transport/local-transport.js:64:11
exports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
exports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14

This is not a problem in JSTOR because I can still import all bibliographic data in Zotero from the JSTOR resource.

Related Objects

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 18 2019, 11:46 PM
Aschmidt updated the task description. (Show Details)Feb 18 2019, 11:48 PM

The browser console output looks like a problem with some browser extension, or with the console (developer tools) itself, rather than VisualEditor.

matmarex removed a subscriber: matmarex.
Aschmidt added a comment.EditedFeb 19 2019, 12:00 AM

Just to make sure: This worked before, and it only happens in JSTOR, no other resource is affected. I did not change anything about the local configuration.

Mvolz added a subscriber: Mvolz.Feb 26 2019, 10:23 AM

Just to make sure: This worked before, and it only happens in JSTOR, no other resource is affected. I did not change anything about the local configuration.

Thanks for reporting this; it looks like it's getting stuck in a redirect loop on our end. Neither citoid nor zotero can handle this; it causes a "caught at recursion" error in citoid, and gives zotero's translation-server an internal server error. The problem is likely upstream with JSTOR changing how it does redirects.

However, the browser seems to handle the redirect okay, so there may be stuff we can do on our end about this. I'll file a bug upstream with zotero.

Mvolz triaged this task as Low priority.Feb 26 2019, 10:23 AM
Mvolz renamed this task from Visual editor fails to create reference from JSTOR to Citoid / zotero unable to follow JSTOR stable links redirects.Feb 26 2019, 11:17 AM
Mvolz moved this task from Backlog to Zotero on the Citoid board.Feb 26 2019, 11:17 AM

So it turns out that JSTOR is just blocking us. They've done this in the past: T88323

Mvolz renamed this task from Citoid / zotero unable to follow JSTOR stable links redirects to JSTOR is blocking citoid IPs.Feb 26 2019, 12:08 PM
Mvolz moved this task from Zotero to Production on the Citoid board.Feb 26 2019, 12:19 PM
Mvolz added a project: serviceops.

@Mvolz Do you already have a contact at JSTOR to help with this? If not we'd be happy to help!

Mvolz added a comment.Feb 28 2019, 6:54 PM

@Mvolz Do you already have a contact at JSTOR to help with this? If not we'd be happy to help!

I don't, that'd be great!

Cirdan added a subscriber: Cirdan.Mar 2 2019, 4:07 PM
Mvolz closed this task as Resolved.Mar 4 2019, 9:58 PM

They've whitelisted our IPs on request, so this is now resolved.

Joe added a subscriber: Joe.Mar 5 2019, 7:41 AM

@Mvolz this means we can reconfigure citoid to use both proxies?

Mvolz added a comment.Mar 6 2019, 10:13 AM

@Mvolz this means we can reconfigure citoid to use both proxies?

I don't know, but I'll email you the IPs I sent them :).