Page MenuHomePhabricator

Allow extensions to create subsections on the list of special pages
Closed, ResolvedPublic

Description

@mwjames on SMW's issue tracker writes:

While trying to consolidate our special pages into one coherent section it became clear that collecting all pages into one section creates some inconsistencies where users cannot clearly distinguish pages (by topic, or interest) on a subsection level (as shown below). We would require a tiny change to SpecialSpecialpages in MW-core to allow us to define a subsection using / as separator in the group name.

Mock-up:

Unless someone beats me to it, I'll put something in Gerrit tomorrow.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 19 2019, 2:45 AM
Kghbln added a subscriber: Kghbln.Feb 19 2019, 9:51 AM

@Nikerabbit I think this would also allow for improvements finding the pages related to the Translate extension. After a while I know in which sections to look for the special pages provided but it took quite some time for me as an occasional user.

On one hand I am not in favor of extension specific sections on Special:AllPages, but on the other hand I do think subsections makes it easier to find pages on that special page.

I could think of either a generic top level Language and translation section that is not specific to Translate, where most of those pages could be placed, or subsections on some of the long listings with multiple translation related special pages. That brings up a question: whether and how extensions could add subsections to already existing top level sections?

Kghbln added a comment.EditedFeb 19 2019, 12:56 PM

On one hand I am not in favor of extension specific sections on Special:AllPages, but on the other hand I do think subsections makes it easier to find pages on that special page.

For extensions or extensions suites providing just one special page it would not really make sense to have an extra section. However I do not think that this will happen anyways and if it does I do not see why it should hurt badly. On the other hand extensions related to structured data or translations with providing multiple pages spread over multiple of the existing sections it would indeed provide gains to user.

That brings up a question: whether and how extensions could add subsections to already existing top level sections?

I am not absolutely sure but doesn't the proposed patch allow to do just this, i.e. add subsections to an existing section? It could be SMW specific though.

Change 493789 had a related patch set uploaded (by Kghbln; owner: Kghbln):
[mediawiki/core@master] Allows to add subsections to special pages groups on special page "Specialpages"

https://gerrit.wikimedia.org/r/493789

Change 493789 merged by jenkins-bot:
[mediawiki/core@master] Allows to add subsections to special pages groups on special page "Specialpages"

https://gerrit.wikimedia.org/r/493789

Change 494267 had a related patch set uploaded (by Kghbln; owner: Kghbln):
[mediawiki/core@REL1_31] Allows to add subsections to special pages groups on special page "Specialpages"

https://gerrit.wikimedia.org/r/494267

Change 494268 had a related patch set uploaded (by Kghbln; owner: Kghbln):
[mediawiki/core@REL1_32] Allows to add subsections to special pages groups on special page "Specialpages"

https://gerrit.wikimedia.org/r/494268

Kghbln added a comment.Mar 4 2019, 4:56 PM

@MarkAHershberger Thanks a ton for your review and merging. I have done cherry-picks to REL1_31 and REL1_32 to allow support for all versions starting with 1.31. It does not make sense to back-port this to REL1_27 though.

Change 494267 abandoned by Kghbln:
Allows to add subsections to special pages groups on special page "Specialpages"

Reason:
Not a bug fix.

https://gerrit.wikimedia.org/r/494267

Change 494268 abandoned by Kghbln:
Allows to add subsections to special pages groups on special page "Specialpages"

Reason:
Not a bug fix

https://gerrit.wikimedia.org/r/494268

Kghbln closed this task as Resolved.Mar 4 2019, 5:05 PM
Kghbln reassigned this task from MarkAHershberger to mwjames.
Kghbln triaged this task as Low priority.
Kghbln removed a project: Patch-For-Review.

@MarkAHershberger Thanks a ton for your review and merging. I have done cherry-picks to REL1_31 and REL1_32 to allow support for all versions starting with 1.31. It does not make sense to back-port this to REL1_27 though.

Ok, since it is not a bug fix we have to leave it at it. Anyways, thanks for the help!