Page MenuHomePhabricator

Setup CI for search/glent
Closed, ResolvedPublic

Description

https://gerrit.wikimedia.org/r/admin/projects/search/glent is a maven project and should be setup with exactly the same options that we use for search/extra.

Event Timeline

dcausse created this task.Feb 20 2019, 9:03 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 20 2019, 9:03 AM
dcausse triaged this task as Medium priority.Feb 20 2019, 9:04 AM
dcausse added subscribers: hashar, Gehel.

looks like it was already done in https://gerrit.wikimedia.org/r/c/integration/config/+/489800 but sadly this does not seem to be effective, CI is not triggered, see test patch: https://gerrit.wikimedia.org/r/c/search/glent/+/491658

Gehel added a comment.Feb 20 2019, 9:12 AM

looks like it was already done in https://gerrit.wikimedia.org/r/c/integration/config/+/489800 but sadly this does not seem to be effective, CI is not triggered, see test patch: https://gerrit.wikimedia.org/r/c/search/glent/+/491658

This has been merged just a few minutes ago. It should work in a moment.

dcausse assigned this task to Gehel.Feb 20 2019, 9:20 AM
dcausse moved this task from Incoming to Needs Reporting on the Discovery-Search (Current work) board.

I have deployed the CI change several minutes after it got merged, I was busy reviewed another patch by Gehel. Sorry.

Seems some maven step fail due to forbiddenapis:2.6:check (check-forbidden-apis) @ glent ---

I confirm that this is working as intended, the failure is expected.

debt closed this task as Resolved.Feb 22 2019, 8:43 PM