Page MenuHomePhabricator

Build failures for Elastica and CirrusSearch on REL1_32
Closed, DeclinedPublic

Description

Elastica does not seem able to find a class from the composer dependency ruflin/elastica:

13:01:17 Fatal error: Class undefined: Elastica\Exception\InvalidException in /workspace/src/extensions/Elastica/tests/phpunit/UtilTest.php on line 40
13:01:17 Destructor threw an object exception: exception 'MWException' with message 'UtilTest::tearDown() must call parent::tearDown()' in /workspace/src/tests/phpunit/MediaWikiTestCase.php:158

Cirrus has similar problems tests cannot find \Elastica\Query\MatchAll but with an additional phan failure on the missing UsageException class from MW Core.

Test patches:

Event Timeline

dcausse created this task.Feb 20 2019, 1:21 PM
Restricted Application added a project: Discovery-Search. · View Herald TranscriptFeb 20 2019, 1:21 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
dcausse moved this task from Backlog to Extensions on the MW-1.32-release board.Feb 20 2019, 1:21 PM
dcausse moved this task from Extensions to Backlog on the MW-1.32-release board.

This seems very similar to T215713 (probably duplicate).

Copying Krinkle comment here:

Might be related to, or duplicate of T189560: mediawiki/vendor REL1_* no longer ship dependencies for wmf extensions that are not in the mediawiki tarball.
In particular:

so if you want to have a vendor inside of AbuseFilter we'd have to add something like:

require __DIR__ . '/vendor/autoload.php';

somewhere (I have no idea where this would go).

This is what the following code in extension.json does:

"load_composer_autoloader": true
greg added a subscriber: greg.

Sorry for the late response, is this still an issue for you?

Reedy closed this task as Declined.Tue, Apr 7, 1:14 AM