Page MenuHomePhabricator

Drop support for PHPUnit 6.x
Closed, DuplicatePublic

Description

PHPUnit 7.x requires PHP 7.1+.

Related Objects

Event Timeline

Jdforrester-WMF changed the task status from Open to Stalled.Feb 21 2019, 4:37 PM
Jdforrester-WMF triaged this task as Lowest priority.
Jdforrester-WMF created this task.
Krinkle moved this task from Inbox to PHPUnit on the MediaWiki-Core-Testing board.Apr 5 2019, 3:51 PM
Reedy moved this task from Backlog to MediaWiki core on the PHP 7.1 support board.Jun 8 2019, 11:49 PM

I want to wait for all the blockers to solve, we can jump directly to PHPUnit 8. Since we intend to directly support PHP 7.2+ in the future. PHPUnit 8 support PHPUnit 7.2/7.3/7.4, and 7.X does not support PHP 7.4.