Page MenuHomePhabricator

Help panel: too much cross-hatching animation
Closed, ResolvedPublic

Description

As described by @Catrope:

Before this patch in T216131, the title bar of the help panel would briefly get the pending animation (cross-hatching) when you focus the search input. But with this patch, this happens on every key press. More specifically, on every key press, first the title bar will become pending, then it'll immediately stop being pending again, and only then will the search input itself become pending (and stay that way until the results arrive). Probably not a big deal but it looks a bit weird.
I traced the cause in the debugger, and it seems to come from calling .executeAction( 'search' ): any call to executeAction sets the pending state on the title bar.

Event Timeline

Change 492229 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] Help Panel: Rewire search input action

https://gerrit.wikimedia.org/r/492229

kostajh claimed this task.Feb 22 2019, 2:12 AM
kostajh moved this task from Incoming to Code Review on the Growth-Team (Current Sprint) board.

Change 492229 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Help Panel: Rewire search input action

https://gerrit.wikimedia.org/r/492229

Etonkovidova closed this task as Resolved.Feb 22 2019, 7:45 PM