Page MenuHomePhabricator

Santali font shown as square boxes in thumbnail version of a specific SVG file
Closed, ResolvedPublic

Description

Santali font in the file in being displayed as unrecognised characters

File: https://commons.wikimedia.org/wiki/File:Hand_pump-sat.svg

Related Objects

StatusSubtypeAssignedTask
OpenBUG REPORTNone
OpenNone
DuplicateNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
DuplicateNone
OpenNone
OpenNone
OpenBUG REPORTNone
StalledNone
OpenNone
OpenNone
OpenNone
ResolvedNone
OpenNone
OpenNone
ResolvedNone
Resolved Dcoetzee
ResolvedNone
OpenNone
OpenNone
ResolvedGilles
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
ResolvedNone

Event Timeline

KCVelaga created this task.Feb 23 2019, 6:05 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 23 2019, 6:05 PM
KCVelaga updated the task description. (Show Details)
KCVelaga updated the task description. (Show Details)
KCVelaga updated the task description. (Show Details)

@ASHWANI I kindly request you to add more context about the issue

KCVelaga updated the task description. (Show Details)Feb 23 2019, 6:09 PM
Aklapper changed the task status from Open to Stalled.Feb 23 2019, 6:59 PM

Hi @KCVelaga, thanks for taking the time to report this!
Unfortunately this report lacks some information. If you have time and can still reproduce the problem: Please add a more complete description to this report.
That can be a clear list of specific steps to reproduce the situation, as little details sometimes matter, so that nobody needs to guess how you performed each step, describing actual results and expected results after performing the steps to reproduce, providing a screenshot of the problem, information about your web browser(s).
You can edit the task description by clicking Edit Task.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster. Thanks!


While translating an image in inkspace app the words used were clearly visible but after uploading the picture in commons the words are not recognisable ,it appears as above. Whereas in inkspace the picture was as below
. As my OS is Window 10, i don't had ever such issues in writing article.

Regards
Ashwani

For future reference, please provide 1) steps to reproduce including links; 2) expected outcome; 3) actual outcome, when reporting problems - thanks!

The SVG file itself at https://upload.wikimedia.org/wikipedia/commons/3/35/Hand_pump-sat.svg is shown correctly for me in Firefox 65.
The thumbnail preview at https://upload.wikimedia.org/wikipedia/commons/thumb/3/35/Hand_pump-sat.svg/528px-Hand_pump-sat.svg.png has font issues.

Opening the SVG file locally in Inkscape, I get the message Font 'Verdana' substituted with 'DejaVu Sans'.

@ASHWANI: Does the problem in the thumbnail images also happen when you use a free and supported font instead of "Verdana"?
See https://commons.wikimedia.org/wiki/Help:SVG#Font_substitution_and_fallback_fonts and https://meta.wikimedia.org/wiki/SVG_fonts

Aklapper renamed this task from Santali font issues in SVG rendering to Santali font shown as square boxes in thumbnail version of a specific SVG file.Feb 24 2019, 1:10 PM

yes I tried with other free supported font like " Noto Sans Ol Chiki" font and "Gurugomke" fonts but both didn't work and gave square boxes.

yes I tried with other free supported font like " Noto Sans Ol Chiki" font and "Gurugomke" fonts but both didn't work and gave square boxes.

@ASHWANI: Where can someone else see that "both fonts didn't work"?
The "File history" at https://commons.wikimedia.org/wiki/File:Hand_pump-sat.svg says that the last version is from Feb23...

hii @Aklapper
Earlier I had tried one image of which i had kept three screen shot worked on inkspace by GuruGomke font. On the right hand side you can see the preview of the text which is showing square boxes. Therefore I had presumed it will not work.


Similary in the case of Noto sans Ol Chiki font also

But as I uploaded both of these two images today morning in common it worked, It is clearly visible.
https://commons.wikimedia.org/wiki/File:Assam-districts-2001-sat.svg
https://commons.wikimedia.org/wiki/File:WestBengalDistricts_numbered-sat.svg

Thanks for support
Regards
Ashwani

A font for Santali is supposed to be installed on the server where the SVG is rendered. @ASHWANI gave several examples of fonts that would work for Santali.

Here are several similar tasks:

The solution for this task about Santali is similar to the solution for these tasks.

Aklapper changed the task status from Stalled to Open.Feb 27 2019, 12:36 PM

@jijiki: Are you sure this is related to librsvg code itself and not to the fonts installed on Wikimedia servers? I don't see (yet) how upgrading librsvg would fix this.

jijiki added a comment.EditedFeb 28 2019, 2:00 PM

@Aklapper my bad, I meant to add it under upgrade to buster, as something we should consider/test when we upgrade again.

Ake added a subscriber: Ake.Jul 12 2019, 10:52 PM

This seems to be fixed.

Aklapper closed this task as Resolved.Jul 19 2019, 11:58 PM

Indeed.