Page MenuHomePhabricator

Migrate extensions and skins to phan 1.2.4
Closed, InvalidPublic

Description

https://codesearch.wmflabs.org/search/?q=%22mediawiki%2Fmediawiki-phan-config%22%3A%20%220.3.0%22&i=nope&files=&repos=

Steps to upgrade:

Examples:

Please use the Gerrit topic new-phan-plz: https://gerrit.wikimedia.org/r/q/topic:%22new-phan-plz%22+(status:open%20OR%20status:merged)

Event Timeline

Legoktm created this task.Feb 24 2019, 5:12 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 24 2019, 5:12 AM
Legoktm updated the task description. (Show Details)Feb 24 2019, 5:16 AM
Legoktm updated the task description. (Show Details)Feb 24 2019, 5:46 AM
Zoranzoki21 added a subscriber: Zoranzoki21.

I think to this can be tagged with good first bug because should be easy

Change 492533 had a related patch set uploaded (by Zoranzoki21; owner: Zoranzoki21):
[mediawiki/extensions/3D@master] Migrate to newer phan

https://gerrit.wikimedia.org/r/492533

@Legoktm I think you should include this bug in commit messages of your patches?

Legoktm closed this task as Invalid.Feb 24 2019, 7:13 AM

I'm actually going to file individual bugs for each repo to make this easier to keep track of.

I think to this can be tagged with good first bug because should be easy

Some repositories will be incredibly trivial, and others will be a lot of work.