Page MenuHomePhabricator

Upgrade Variables extension to use newer phan
Closed, ResolvedPublic4 Story Points

Description

Variables needs to be upgraded to a newer version of phan, our PHP static analysis tool. This brings in
over 2 years of upstream improvements and lots of bug fixes.

Please follow the instructions on how to migrate at https://www.mediawiki.org/wiki/Continuous_integration/Tutorials/Add_phan_to_a_MediaWiki_extension#Migrating_from_phan_0.8.0.

Please also set the Gerrit topic for all patches related to this effort with new-phan-plz.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 24 2019, 7:29 AM
MGChecker triaged this task as High priority.Feb 26 2019, 7:49 PM
MGChecker moved this task from Backlog to Maintenance on the MediaWiki-extensions-Variables board.
MGChecker set the point value for this task to 4.
MGChecker added a subscriber: MGChecker.

I plan to take care of this in a few weeks when my schedule clears up. However, if someone else wants to do this, feel free to claim this task!

Change 495820 had a related patch set uploaded (by MGChecker; owner: MGChecker):
[mediawiki/extensions/Variables@master] Migrate to newer phan

https://gerrit.wikimedia.org/r/495820

Change 495820 merged by jenkins-bot:
[mediawiki/extensions/Variables@master] Migrate to newer phan

https://gerrit.wikimedia.org/r/495820

MGChecker closed this task as Resolved.Mar 12 2019, 11:23 AM
MGChecker removed a project: Patch-For-Review.