Page MenuHomePhabricator

[wmf.18] VE on cawiki displays font formatting options in non-Catalan lang
Closed, ResolvedPublic

Description

Start editing any article in VE. Click on the font formatting options, the click on 'More' - some options will be displayed in non-Catalan language.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 27 2019, 11:10 PM

That's how they are translated…

https://translatewiki.net/wiki/MediaWiki:Visualeditor-annotationbutton-small-tooltip/ca
https://translatewiki.net/wiki/MediaWiki:Visualeditor-annotationbutton-big-tooltip/ca

And they have been this way since 2016. There is no software bug here, just incorrect translation. Looking at the author's other contributions, these were clearly meant for Bulgarian (bg) and I have no idea how they ended up in Catalan (ca).

Conveniently, I'm an administrator on Translatewiki, so I deleted the incorrect translations. When they are exported again (this usually happens daily), and when the commit with the update is deployed to cawiki (per the usual schedule), these messages should revert to the English originals, and when a Catalan translator translates them, that version will be exported and deployed.

matmarex moved this task from Incoming to QA on the VisualEditor (Current work) board.
matmarex removed a project: Regression.

(I don't think it was a regression, it probably has always been this way)

matmarex closed this task as Resolved.Feb 28 2019, 4:56 AM
matmarex claimed this task.

Conveniently, I'm an administrator on Translatewiki, so I deleted the incorrect translations. When they are exported again (this usually happens daily), and when the commit with the update is deployed to cawiki (per the usual schedule), these messages should revert to the English originals, and when a Catalan translator translates them, that version will be exported and deployed.

To make sure they are gone for good, the bad translations must be removed from git as well. Otherwise they can be used when generating updated files and hence not getting removed.

matmarex reopened this task as Open.Feb 28 2019, 12:11 PM
matmarex removed matmarex as the assignee of this task.
Arrbee triaged this task as Low priority.Jun 29 2020, 2:47 PM
Jpita closed this task as Resolved.Jun 30 2020, 8:18 AM
Jpita claimed this task.
Jpita added a subscriber: Jpita.

no longer happening

To make sure they are gone for good, the bad translations must be removed from git as well. Otherwise they can be used when generating updated files and hence not getting removed.

This happened in rGVED4f27ec68c9c1: Localisation updates from https://translatewiki.net., I thought that was automatic?

It's still a bit messy. If import runs before export, it will import the just-deleted translations. Looks like this did not happen in this case.