Page MenuHomePhabricator

View 'hewiki_p.page' references invalid table(s) or column(s) or function(s) or definer/invoker of view lack rights to use them
Closed, ResolvedPublic

Description

Starting 2 hours ago randomly getting this error (sometimes eswiki_p, sometimes ukwiki_p)
host = s1.analytics.db.svc.eqiad.wmflabs
user = s53381
@Bstorm would you mind looking into that? Looks similar to T210978, but back then it was reproducible 100%, now it is random

Event Timeline

Ghuron created this task.Feb 28 2019, 8:33 AM
Restricted Application added subscribers: Base, Aklapper. · View Herald TranscriptFeb 28 2019, 8:33 AM
Ghuron updated the task description. (Show Details)Feb 28 2019, 8:35 AM

Still experiencing problems with hewiki_p (and sometimes eswiki_p). The rest is ok

Bstorm added a comment.Mar 1 2019, 4:44 PM

Random suggests that one of the two analytics replicas didn't get the change. There isn't a schema change in progress like there was then (I hope?), but I don't know. I'll Re-run on those. There's some changes that are needed in general anyway for an upcoming schema change.

Bstorm added a comment.Mar 1 2019, 4:46 PM

Looks like there is a change in progress. It just broke the script that recreates the views. I'll try to get in the loop and fix the script as well.

Bstorm added a comment.Mar 1 2019, 4:49 PM

comment_text already doesn't work, and apparently it is still hidden in the definition file for the views. We tried to remove it here T212972

Bstorm added a comment.Mar 1 2019, 4:52 PM

Bleh, I have that backwards. comment_text should work and doesn't there because of some hidden join condition or something :)

Bstorm added a comment.Mar 1 2019, 4:53 PM

So that means there might not be any changes, but that one or another of the servers is missing an update.

Bstorm added a comment.EditedMar 1 2019, 5:29 PM

Ok, I rebuilt those two wiki db's views on all three replicas for good measure. Please check.

Ghuron added a comment.Mar 1 2019, 5:45 PM

thanks, no problems now!

Ghuron closed this task as Resolved.Mar 1 2019, 5:45 PM