Page MenuHomePhabricator

Beta site api.phps gets - RuntimeException: RedisConnectionPool requires a Redis client library
Closed, ResolvedPublic

Description

https://wikidata.beta.wmflabs.org/w/api.php
https://en.wikipedia.beta.wmflabs.org/w/api.php

Fatal error: Uncaught RuntimeException: RedisConnectionPool requires a Redis client library. See https://www.mediawiki.org/wiki/Redis#Setup in /srv/mediawiki/php-master/includes/libs/redis/RedisConnectionPool.php:80 Stack trace: #0 /srv/mediawiki/php-master/includes/libs/redis/RedisConnectionPool.php(152): RedisConnectionPool->__construct(Array, '8d9cd2955414c7d...') #1 /srv/mediawiki/php-master/includes/libs/objectcache/RedisBagOStuff.php(77): RedisConnectionPool::singleton(Array) #2 /srv/mediawiki/php-master/includes/objectcache/ObjectCache.php(216): RedisBagOStuff->__construct(Array) #3 /srv/mediawiki/php-master/includes/ServiceWiring.php(242): ObjectCache::newFromParams(Array) #4 /srv/mediawiki/php-master/includes/libs/services/ServiceContainer.php(430): Wikimedia\Services\ServiceContainer->{closure}(Object(MediaWiki\MediaWikiServices)) #5 /srv/mediawiki/php-master/includes/libs/services/ServiceContainer.php(414): Wikimedia\Services\ServiceContainer->createService('MainObjectStash') #6 /srv/mediawiki/php-master/includ in /srv/mediawiki/php-master/includes/libs/redis/RedisConnectionPool.php on line 80
(172.16.4.106)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 28 2019, 12:25 PM
Addshore triaged this task as High priority.Feb 28 2019, 4:43 PM

Appears to be limited to PHP7 – I could only reproduce it after enabling the PHP7 beta feature.

Cparle added a subscriber: Cparle.Feb 28 2019, 5:12 PM

Hm, but at least the php-redis package itself seems to be installed on e. g. deployment-mediawiki-09 (which is the server of an error response I just got, according to the response headers)… is some config missing?

Reedy assigned this task to Joe.Feb 28 2019, 5:20 PM
Reedy added a subscriber: Joe.

Hm, but at least the php-redis package itself seems to be installed on e. g. deployment-mediawiki-09 (which is the server of an error response I just got, according to the response headers)… is some config missing?

Wrong versions, IIRC

@Joe is going to fix it :)

Joe added a comment.Feb 28 2019, 5:54 PM

Applies magic wand solved!

Jokes aside, we just needed to restart php-fpm to catch up with software updates.

Reedy closed this task as Resolved.Feb 28 2019, 8:30 PM
Addshore reopened this task as Open.EditedMar 6 2019, 11:21 AM

Mentioned in SAL (#wikimedia-releng) [2019-03-06T11:33:39Z] <Lucas_WMDE> lucaswerkmeister-wmde@deployment-mediawiki-09:~$ sudo systemctl restart php7.2-fpm # T217323

That seems to have fixed it… do we need to restart php-fpm on other servers too?

Hm, I only see two deployment-mediawiki- servers in Horizon (-07 and -09), and I assume the other one is the one @Joe restarted already, so I guess this might be done.

Addshore closed this task as Resolved.Mar 6 2019, 12:18 PM

Just to clarify the root cause: Beta is getting updated via unattended-upgrades, but unattended-upgrades isn't restarting services after updates.

Krenair added a subscriber: Krenair.Mar 9 2019, 3:12 AM