Page MenuHomePhabricator

Page Preview fails on redirected articles
Closed, InvalidPublic

Description

A page Preview is unavailable error is generated when attempting to view the preview while hovering over a link of a page, if the page is a redirect.

Event Timeline

RhinosF1 created this task.Feb 28 2019, 9:47 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 28 2019, 9:47 PM
Reedy added a subscriber: Reedy.Feb 28 2019, 10:10 PM

I can't replicate it. Hovering over != just gets a little popup, not an error

I'll try to get back to you guys tommorow

I cannot reproduce with a clean redirect link. (in Firefox 65.0.1 (Linux) nor in Chromium 71)
You can Test it at https://en.wikipedia.org/w/index.php?title=User:Quiddity_(WMF)/sandbox&oldid=885582095
My result is a proper HTTP 302, and fully functional PagePreview:

(Links and examples always help! Please try to make life easy for each other :-)

RhinosF1 closed this task as Invalid.Mar 1 2019, 7:00 AM

I cannot reproduce with a clean redirect link. (in Firefox 65.0.1 (Linux) nor in Chromium 71)
You can Test it at https://en.wikipedia.org/w/index.php?title=User:Quiddity_(WMF)/sandbox&oldid=885582095
My result is a proper HTTP 302, and fully functional PagePreview:

(Links and examples always help! Please try to make life easy for each other :-)

I'll reopen if I can verify later today.

(For future reference, please include browser information, browser version information, test with a clean browser profile, and include a link that allows others to test. Thanks!)

(For future reference, please include browser information, browser version information, test with a clean browser profile, and include a link that allows others to test. Thanks!)

@Aklapper - I normally do, I didn't report this immediately and was in a bit of a rush. I'll try and work out what went on later.

I've been crazy busy but I will work out what caused the issue