Page MenuHomePhabricator

Requesting access to stat1007 for sukhe
Closed, ResolvedPublicRequest

Description

Username: sukhe
Full name: Sukhbir Singh
Public key:

ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIAPE0Y9KGVkwRR1edkEe2/5LShc9s6nynwFQg+v9Uemd sukhe@sukhe

I need access to stat1007 as that hosts the traffic anomaly detector. I need to maintain/modify it for my current project. Related tickets: T215379, T183291.

SRE Clinic Duty Checklist for Access Requests

Most requirements are outlined on https://wikitech.wikimedia.org/wiki/Requesting_shell_access

This checklist should be used on all access requests to ensure that all steps are covered. This includes expansion to access. Please do not check off items on the list below unless you are in Ops and have confirmed the step.

  • - User has signed the L3 Acknowledgement of Wikimedia Server Access Responsibilities Document.
  • - User has a valid NDA on file with WMF legal. (This can be checked by Operations via the NDA tracking sheet & is included in all WMF Staff/Contractor hiring.)
  • - User has provided the following: wikitech username, preferred shell username, email address, and full reasoning for access (including what commands and/or tasks they expect to perform.
  • - User has provided a public SSH key. This ssh key pair should only be used for WMF cluster access, and not share with any other service (this includes not sharing with WMCS access, no shared keys.)
  • - access request (or expansion) has sign off of WMF sponsor/manager (sponser for volunteers, manager for wmf staff)
  • - non-sudo requests: 3 business day wait must pass with no objections being noted on the task
  • - Patchset for access request

Event Timeline

ssingh created this task.Mar 1 2019, 7:12 PM
Restricted Application added a project: Operations. · View Herald TranscriptMar 1 2019, 7:12 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
ssingh updated the task description. (Show Details)Mar 1 2019, 7:14 PM
RobH assigned this task to Nuria.Mar 1 2019, 10:48 PM
RobH updated the task description. (Show Details)
RobH added a subscriber: RobH.

So for this to be approved, we need the approval of the analytics team (since they manage the server.) We'll also need them to tell us exactly what groups to include.

I support @ssingh's request. Access would help his work on a project he's doing as a Ford-Mozilla Open Web Fellow for Wikimedia.

elukey added a subscriber: elukey.Mar 4 2019, 12:21 PM

@Tbayer what kind of access is needed? I guess analytics-privatedata-users but just want to be sure :)

@Tbayer what kind of access is needed? I guess analytics-privatedata-users but just want to be sure :)

Per https://wikitech.wikimedia.org/wiki/Analytics/Data_access#Host_access_granted that looks correct, but @Nuria / Analytics Engineering should be able to confirm for sure.

jbond triaged this task as Normal priority.Mar 4 2019, 8:32 PM
Nuria added a comment.Mar 5 2019, 8:49 PM

@ssingh do you have an NDA on file that lists the expire date for access? @Slaporte might know the answer to this.

ssingh added a comment.Mar 5 2019, 9:04 PM

@ssingh do you have an NDA on file that lists the expire date for access? @Slaporte might know the answer to this.

June 30, 2019. Thanks.

Nuria added a comment.Mar 5 2019, 10:38 PM

Can @Slaporte confirm NDA was signed?

jbond added a subscriber: jbond.Mar 7 2019, 11:49 AM

Can @Slaporte confirm NDA was signed?

Yes, he has an NDA with the Foundation.

Nuria added a comment.Mar 13 2019, 9:21 PM

Ok, approved on my end please see June 30th end date.

Vgutierrez added a subscriber: Nuria.

Change 496379 had a related patch set uploaded (by Vgutierrez; owner: Vgutierrez):
[operations/puppet@production] admin: create user with analytics-privatedata access for sukhe

https://gerrit.wikimedia.org/r/496379

Change 496379 merged by Vgutierrez:
[operations/puppet@production] admin: create user with analytics-privatedata access for sukhe

https://gerrit.wikimedia.org/r/496379

Vgutierrez closed this task as Resolved.Mar 18 2019, 8:45 AM
Vgutierrez updated the task description. (Show Details)
Vgutierrez removed a project: Patch-For-Review.