Page MenuHomePhabricator

Global renames are very slow
Closed, ResolvedPublic

Description

I'd say since we fixed T215107: Global rename of The_Photographer → Wilfredor: supervision needed with rERENeb847453fece: Batch renames in image tables renames are being very slow.

This rename started at 15:09, 4 March 2019 (UTC) and as of the time I'm writting (15:49, 4 March 2019 (UTC)) the rename is still in progress.

The account does not have a particularly high edit count.

Could eb847453fece be the cause of this recent slowness?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Same issue I've reported in T217203#4988080. It seems this is happening from time to time. Some requests are processed slower than before, whereas some other are stuck at the beginning for a while. I've also noticed that the issue is not related to single requests at a time. For example, I could see up to 7 renames getting stuck until they all started together.

Tgr added a comment.Mar 5 2019, 9:27 PM

Maybe jobs are held in the queue for long? It would be weird, we have used use the same kind of job already for edits, the patch just moved images there.

MarcoAurelio added a comment.EditedMar 7 2019, 9:52 AM

It looks to me that it's not the renaming process itself but the speed in which the job is sent to the wiki to process. That is, renames are now "queued" for longer than before. EventBus issue?

Example: https://meta.wikimedia.org/wiki/Special:GlobalRenameProgress?username=WhiteDreamsIndaHouse started at 09:51, 7 March 2019 but it was not until 09:54, 7 March 2019 when the first rename happened.

I am renaming users today, and it looks they're fast again.

MarcoAurelio closed this task as Resolved.Mar 13 2019, 9:59 PM

Looks everything is back to normal.

MarcoAurelio moved this task from Backlog to Closed on the GlobalRename board.Aug 28 2019, 7:38 PM