Page MenuHomePhabricator

Some article text excerpts in the search results display unhelpful template spew instead of actual text only
Closed, InvalidPublic

Description

Steps to reproduce:

Go to https://de.wikipedia.org/w/index.php?search=franz+josef+neuseeland

Expected outcome:

Readable text previews for each search result article. The text preview for the second search result (Franz-Josef-Gletscher article) should be something like
Der Franz-Josef-Gletscher (Englisch: Franz Josef Glacier, Māori: Kā Roimata o Hine Hukatere) ist ein etwa ...

Actual outcome:

The text preview for the second search result (Franz-Josef-Gletscher article) includes some template spew from Template:Infobox_Gletscher:
Vorlage:Infobox Gletscher/Wartung/Bildbeschreibung fehlt Der Franz-Josef-Gletscher (Englisch: Franz Josef Glacier, Māori: Kā Roimata o Hine Hukatere) ist ein etwa

This might be something to fix on-wiki and hence invalid here, but I found no docs on https://www.mediawiki.org/wiki/Help:CirrusSearch how to fix this. Please point to docs. Thanks in advance!

Event Timeline

Malyacko created this task.Mar 4 2019, 4:03 PM
Restricted Application added a project: Discovery-Search. · View Herald TranscriptMar 4 2019, 4:03 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
EBernhardson closed this task as Invalid.Mar 7 2019, 6:16 PM
EBernhardson added a subscriber: EBernhardson.

Managing what templates are included in the search index should be handled by the editors who know best what templates are meaningful where. Documentation at: https://www.mediawiki.org/wiki/Help:CirrusSearch#Exclude_content_from_the_search_index

If you need further assistance feel free to reopen this ticket.

Since you looked at the docs and didn't find this, perhaps we need to adjust the documentation? The heading for that section certainly doesn't make it obvious that content moved out of the text to an auxiliary field will also change the highlighting.

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptTue, May 14, 12:39 PM