Page MenuHomePhabricator

Connect wikimaniawiki to Wikidata
Closed, ResolvedPublic3 Story Points

Description

Make sure that https://wikimania.wikimedia.org has all the set up done to be one of Wikidata's client:

  • ability to include data from Wikidata on the wiki (parser function, arbitrary access)
  • ability to add interwikilinks in Wikidata

Details

Related Gerrit Patches:
operations/mediawiki-config : masterSet $wmgWikibaseSiteGroup for wikimaniawiki
mediawiki/extensions/WikimediaMessages : wmf/1.33.0-wmf.22Add messages for Wikimania wiki in sidebar
operations/mediawiki-config : masterAdd wikimaniawiki to another special group in Wikibase client
mediawiki/extensions/WikimediaMessages : wmf/1.33.0-wmf.19Add messages for Wikimania wiki in sidebar
mediawiki/extensions/WikimediaMessages : masterAdd messages for Wikimania wiki in sidebar
operations/mediawiki-config : masterAdd wikimania as a special group to wikidata sitelinks
operations/mediawiki-config : masterAdd wikimaniawiki to wikidataclient.dblist

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 6 2019, 8:17 AM
Addshore triaged this task as Normal priority.Mar 19 2019, 7:56 AM
Addshore set the point value for this task to 3.Mar 19 2019, 3:47 PM
Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptMar 19 2019, 5:31 PM

The problem is two-fold. One is that wikimaniawiki is not linkable in wikidata (the site link is not possible). This is rather easiliy fixable and I can do it. The second part is that wikimaniawiki become a client of wikidata. That needs creating tables and such. I can do that too.

Change 497578 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[operations/mediawiki-config@master] Add wikimania as a special group to wikidata sitelinks

https://gerrit.wikimedia.org/r/497578

Change 497579 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[operations/mediawiki-config@master] Add wikimaniawiki to wikidataclient.dblist

https://gerrit.wikimedia.org/r/497579

Change 497579 merged by jenkins-bot:
[operations/mediawiki-config@master] Add wikimaniawiki to wikidataclient.dblist

https://gerrit.wikimedia.org/r/497579

Mentioned in SAL (#wikimedia-operations) [2019-03-20T11:40:54Z] <ladsgroup@deploy1001> Synchronized dblists/wikidataclient.dblist: SWAT: [[gerrit:497579|Add wikimaniawiki to wikidataclient.dblist (T217730)]] (duration: 00m 50s)

Change 497578 merged by jenkins-bot:
[operations/mediawiki-config@master] Add wikimania as a special group to wikidata sitelinks

https://gerrit.wikimedia.org/r/497578

Mentioned in SAL (#wikimedia-operations) [2019-03-20T11:44:57Z] <ladsgroup@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:497578|Add wikimania as a special group to wikidata sitelinks (T217730)]] (duration: 00m 50s)

Yay! Thanks Amir!
ping @Eric_Luth_WMSE
Feel free to test it, if you have any issue, let us know :)

I don't see the links to other wiki's on Wikimaniawiki. Also checked nlwiki and there I see a link to Wikimaniawiki.

I don't see the links to other wiki's on Wikimaniawiki. Also checked nlwiki and there I see a link to Wikimaniawiki.

Very true. Two examples

This comment was removed by Lea_Lacroix_WMDE.

Hello all,

Quick update: the links don't appear because the section "In other projects" doesn't seem to be enabled on wikimaniawiki. (see how it is on meta for example). Once this section is enabled, you should be able to have the other wikimedia projects links displayed.

(btw, the wikimediawiki link is displayed as "⧼wikibase-otherprojects-wikimania⧽", can someone fix it?

(btw, the wikimediawiki link is displayed as "⧼wikibase-otherprojects-wikimania⧽", can someone fix it?

That needs to be done via translatewiki.net. Or locally on each project by creating MediaWiki:Wikibase-otherprojects-wikimania and add the localized name there.

Hello all,
Quick update: the links don't appear because the section "In other projects" doesn't seem to be enabled on wikimaniawiki. (see how it is on meta for example). Once this section is enabled, you should be able to have the other wikimedia projects links displayed.

I will fix it

(btw, the wikimediawiki link is displayed as "⧼wikibase-otherprojects-wikimania⧽", can someone fix it?

and this one.

Change 498092 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[mediawiki/extensions/WikimediaMessages@master] Add messages for Wikimania wiki in sidebar

https://gerrit.wikimedia.org/r/498092

Change 498097 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[mediawiki/extensions/WikimediaMessages@wmf/1.33.0-wmf.19] Add messages for Wikimania wiki in sidebar

https://gerrit.wikimedia.org/r/498097

Change 498092 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@master] Add messages for Wikimania wiki in sidebar

https://gerrit.wikimedia.org/r/498092

Added a copy to enwiki for now so it is not broken before this is backported

https://en.wikipedia.org/wiki/MediaWiki:Wikibase-otherprojects-wikimania

Change 498113 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[mediawiki/extensions/WikimediaMessages@wmf/1.33.0-wmf.22] Add messages for Wikimania wiki in sidebar

https://gerrit.wikimedia.org/r/498113

Change 498097 abandoned by Ladsgroup:
Add messages for Wikimania wiki in sidebar

https://gerrit.wikimedia.org/r/498097

Change 498140 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[operations/mediawiki-config@master] Add wikimaniawiki to another special group in Wikibase client

https://gerrit.wikimedia.org/r/498140

Change 498140 merged by jenkins-bot:
[operations/mediawiki-config@master] Add wikimaniawiki to another special group in Wikibase client

https://gerrit.wikimedia.org/r/498140

Mentioned in SAL (#wikimedia-operations) [2019-03-21T23:08:51Z] <jforrester@deploy1001> Synchronized wmf-config/Wikibase.php: SWAT T217730 Add wikimaniawiki to another special group in Wikibase client (duration: 00m 49s)

Change 498113 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@wmf/1.33.0-wmf.22] Add messages for Wikimania wiki in sidebar

https://gerrit.wikimedia.org/r/498113

Change 498440 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[operations/mediawiki-config@master] Set $wmgWikibaseSiteGroup for wikimaniawiki

https://gerrit.wikimedia.org/r/498440

Lydia_Pintscher closed this task as Resolved.Mar 25 2019, 3:44 PM
Mbch331 reopened this task as Open.Mar 25 2019, 5:35 PM

@Lydia_Pintscher I see 1 unmerged patch related to this ticket. That doesn't look fixed to me. And I noticed that Template:Done still doesn't show interwiki links and I can't link it to other wikis. I click on Add links in the sidebar, the popup appears and when I enter nlwiki in the first field, nothing happens. (Could be caused by the unmerged patch that needs to be deployed).

Yes, there's one small bit that needs deployment which I couldn't do in Friday as we don't deploy on Fridays. I will do it tomorrow.

Change 498440 merged by jenkins-bot:
[operations/mediawiki-config@master] Set $wmgWikibaseSiteGroup for wikimaniawiki

https://gerrit.wikimedia.org/r/498440

Mentioned in SAL (#wikimedia-operations) [2019-03-26T11:28:30Z] <ladsgroup@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:498440|Set $wmgWikibaseSiteGroup for wikimaniawiki (T217730)]] (duration: 00m 49s)

Mentioned in SAL (#wikimedia-operations) [2019-03-26T11:40:19Z] <Amir1> ladsgroup@mwmaint1002:~$ mwscript extensions/Wikibase/lib/maintenance/populateSitesTable.php --wiki=wikimaniawiki --force-protocol https (T217730)

Pages need to be purged before the interwikilinks are shown (tested it with https://wikimania.wikimedia.org/wiki/Template:Done), but then do indeed do work.
And the add links popup now works too. So now this really is resolved.

Works for me. I have purged the few pages that I have done, and they were more predominantly test edits, so less fussed on their updatedness. Thanks @Ladsgroup

Billinghurst closed this task as Resolved.Mar 26 2019, 1:16 PM