Page MenuHomePhabricator

Help panel: impressions with VE are incorrectly marked as reading editor_interface
Closed, ResolvedPublicBUG REPORT

Description

As noted in T215664#5006642

events are not recorded correctly if the Visual Editor is used. Those events are instead recorded as reading events.

Event Timeline

kostajh created this task.Mar 6 2019, 10:03 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 6 2019, 10:03 PM
kostajh changed the subtype of this task from "Task" to "Bug Report".Mar 6 2019, 10:03 PM
MMiller_WMF renamed this task from Help panel impressions with VE are incorrectly marked as reading editor_interface to Help panel: impressions with VE are incorrectly marked as reading editor_interface.Mar 6 2019, 11:37 PM
MMiller_WMF added subscribers: SBisson, Catrope, Etonkovidova and 4 others.
MMiller_WMF added a subscriber: MMiller_WMF.

Hmm. I can reproduce this on cswiki but not locally. A similar problem happens if you edit in wikitext, then switch to VE -- the events recorded while you're in VE are recorded with editor_interface as wikitext.

SBisson claimed this task.Mar 7 2019, 5:55 PM

When VE is the default editor, clicking the edit tab load the editor in place and doesn't reload the page, therefore mw.config.get('wgAction') === 'view'.

I think we can get rid of the readingMode field in the HelpPanelLogger and assume in getEditor() that if we can't find any known editor, we must be in reading mode.

Somewhat related: If you leave the help panel open and save your edit in VE, the page goes back to view mode without reloading and the help panel is still present.

@MMiller_WMF, @nettrom_WMF

I think this started breaking with this patch, which was on wmf.19 and was deployed to our target wikis on Thursday Feb 28 at 8:13pm UTC.

I think it was not obvious initially because events with editor_interface=reading where rejected as invalid because we had forgotten to update the schema. This was fixed yesterday so events with editor_interface=reading started coming in and we could see that they should have been editor_interface=visualeditor.

Change 495076 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/GrowthExperiments@master] Fix reading mode detection

https://gerrit.wikimedia.org/r/495076

Change 495819 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] Help Panel: Set previous editor interface as fallback for mobile

https://gerrit.wikimedia.org/r/495819

Change 495819 abandoned by Sbisson:
Help Panel: Set previous editor interface as fallback for mobile

Reason:
Rolled into I0c86af7f2306d5ec1fb16e01fc676436aa96d35b

https://gerrit.wikimedia.org/r/495819

Change 495076 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Fix reading mode detection

https://gerrit.wikimedia.org/r/495076

Change 496158 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/GrowthExperiments@master] Fix desktop reading mode detection

https://gerrit.wikimedia.org/r/496158

Change 496158 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Fix desktop reading mode detection

https://gerrit.wikimedia.org/r/496158

Change 496242 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/GrowthExperiments@master] Fix missing 'impression' event

https://gerrit.wikimedia.org/r/496242

Change 496264 had a related patch set uploaded (by Catrope; owner: Sbisson):
[mediawiki/extensions/GrowthExperiments@wmf/1.33.0-wmf.21] Fix reading mode detection

https://gerrit.wikimedia.org/r/496264

Change 496242 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Fix missing 'impression' event

https://gerrit.wikimedia.org/r/496242

Change 496326 had a related patch set uploaded (by Catrope; owner: Sbisson):
[mediawiki/extensions/GrowthExperiments@wmf/1.33.0-wmf.21] Fix desktop reading mode detection

https://gerrit.wikimedia.org/r/496326

Change 496327 had a related patch set uploaded (by Catrope; owner: Sbisson):
[mediawiki/extensions/GrowthExperiments@wmf/1.33.0-wmf.21] Fix missing 'impression' event

https://gerrit.wikimedia.org/r/496327

Change 496264 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@wmf/1.33.0-wmf.21] Fix reading mode detection

https://gerrit.wikimedia.org/r/496264

Change 496326 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@wmf/1.33.0-wmf.21] Fix desktop reading mode detection

https://gerrit.wikimedia.org/r/496326

Change 496327 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@wmf/1.33.0-wmf.21] Fix missing 'impression' event

https://gerrit.wikimedia.org/r/496327

Mentioned in SAL (#wikimedia-operations) [2019-03-13T23:30:02Z] <catrope@deploy1001> Synchronized php-1.33.0-wmf.21/extensions/GrowthExperiments/: Instrumentation fixes (T217802) (duration: 00m 57s)

Checked in testwiki - editor_interface attribution is correctly assigned to visualeditor.

Note: to document the issue that still in production test it later:

  • Open an article for editing in VE mode
  • Open Help panel - make an edit (with Help panel open), publish the edit
  • Help panel will record
(1) event: {action: "impression", action_data: "", user_id: 29926, user_editcount: 465, editor_interface: "visualeditor",
(2) 
event: {action: "open", action_data: "", user_id: 29926, user_editcount: 465, editor_interface: "visualeditor", …}
(3) (abbreviated)  "close" should not be on page_ns:0 

action: "close"
action_data: ""
editor_interface: "reading"
is_mobile: false
page_id: 0
page_ns: 0

There probably shouldn't be a close event at all in that case, because the user didn't explicitly close the help panel, right?

There probably shouldn't be a close event at all in that case, because the user didn't explicitly close the help panel, right?

Right - that's why I highlighted it.

Etonkovidova closed this task as Resolved.Mar 14 2019, 8:46 PM