Page MenuHomePhabricator

Update header text on UploadWizard CC0 notice
Closed, ResolvedPublic

Description

What we have:

With the introduction of structured data, there's a need to inform users that some types of contributions must be released under the CC0 license. Currently, for captions, that is done with a notification at the bottom of the Describe step in UploadWizard.

What we need:

The header for the license box might need a little additional language to be more obvious/clear. Please change the existing header to:

"License for captions contributions only (this applies to caption text, NOT the file)"

Details

Related Gerrit Patches:
mediawiki/extensions/UploadWizard : masterUpdate header text on UploadWizard CC0 notice

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 7 2019, 10:57 PM
Ramsey-WMF triaged this task as Low priority.Mar 7 2019, 10:57 PM

@Ramsey-WMF Curious, assuming all tasks for the Multimedia team exist on the Multimedia backlog, should Structured Data Engineering tasks be grabbed by Herald? I didn't want to assume that that was the case, and that there may be a non-trivial amount of tasks on Structured Data Engineering that should not exist on Multimedia :)

Ha78na claimed this task.Mar 11 2019, 4:31 PM
Ha78na moved this task from To Do to Doing on the Structured-Data-Team-Current-Work board.

Change 495730 had a related patch set uploaded (by Ha78na; owner: Ha78na):
[mediawiki/extensions/UploadWizard@master] Update header text on UploadWizard CC0 notice

https://gerrit.wikimedia.org/r/495730

Change 495730 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@master] Update header text on UploadWizard CC0 notice

https://gerrit.wikimedia.org/r/495730

Ramsey-WMF added a comment.EditedApr 23 2019, 8:48 PM

NOT confirmed on production. The proper parenthetical text ("this applies to caption text, NOT the file") does not appear on production as of 4-23. It DOES appear on test Commons though.

I see the correct i18n values on the master branch now. Not clear on what would be the difference between this code and production at this point - @Jdforrester-WMF could you shed some light? I didn't change the key name so maybe cached lang value is appearing? Let me know how to fix.

NOT confirmed on production. The proper parenthetical text ("this applies to caption text, NOT the file") does not appear on production as of 4-23. It DOES appear on test Commons though.

This is because as a deployment hack I had to create the message locally; that issue is now long-passed, so I've deleted it: https://commons.wikimedia.org/wiki/MediaWiki:Mwe-upwiz-license-metadata-title

This should now appear correctly.

thanks @Jdforrester-WMF --- I agree, things look correct on production

Ramsey-WMF closed this task as Resolved.Apr 24 2019, 1:45 AM

Thanks, folks! Good to go now.