Page MenuHomePhabricator

Single name, search failure
Closed, ResolvedPublic

Description

I'm not getting a search result for "garrett marquis" or "Garrett Marquis". Sarah Tinsley listed right next to him in [[Michael Anton]] en.wikipedia article shows up via search, just not Marquis. Two search urls for Marquis are https://en.m.wikipedia.org/w/index.php?search="garrett+marquis" and https://en.m.wikipedia.org/w/index.php?search="Garrett+Marquis"&title=Special%3ASearch&profile=default&fulltext=1 (only case difference in search box terms; both fail); and one url for Tinsley https://en.m.wikipedia.org/w/index.php?search="Sarah+Tinsley"&title=Special%3ASearch&profile=default&fulltext=1 (that succeeds). The Tinsley results show the [[Michael Anton]] article result where both Marquis and Tinsley names reside plus two others for the Sarah Tinsley name. The problem is with the full, in-double-quotes Marquis name. I know search is supposed to be case insensitive but tried both to be sure. This Description expanded via edit per @Aklapper. Thanks much. Hope this is sufficient.

Event Timeline

Swliv created this task.Mar 10 2019, 11:18 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 10 2019, 11:18 PM
Aklapper added a subscriber: Liuxinyu970226.

@Liuxinyu970226: Please don't add random team tags. It's up to teams to decide what they want to track on their workboards.

Hi @Swliv, thanks for taking the time to report this and welcome! Unfortunately this report lacks some information. If you have time and can still reproduce the problem: Please add a more complete description to this report.
On which public website can the issue be seen (exact link), or which MediaWiki version are you running (if it is not on a Wikimedia wiki), etc.
You can edit the task description by clicking Edit Task.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster. Thanks!

Swliv added a comment.Mar 11 2019, 7:29 PM
This comment was removed by Swliv.
Swliv updated the task description. (Show Details)Mar 11 2019, 7:56 PM
Restricted Application added a project: Discovery-Search. · View Herald TranscriptMar 11 2019, 10:15 PM
debt triaged this task as Medium priority.EditedMar 14 2019, 7:42 PM
debt moved this task from needs triage to elastic / cirrus on the Discovery-Search board.
debt added a subscriber: debt.

Ahh...this looks like it is a bug in the pulling of data from the infobox - we'll take a look at it.

debt assigned this task to EBernhardson.Mar 14 2019, 7:49 PM
debt edited projects, added Discovery-Search (Current work); removed Discovery-Search.

Change 496575 had a related patch set uploaded (by EBernhardson; owner: EBernhardson):
[mediawiki/core@master] Improve RemexStripTagHandler working with tables

https://gerrit.wikimedia.org/r/496575

Change 496575 merged by jenkins-bot:
[mediawiki/core@master] Improve RemexStripTagHandler working with tables

https://gerrit.wikimedia.org/r/496575

Once this is deployed (should land on all wikis in two days) it will still take ~8 weeks for all content across all wikis to be reindexed . Pages that are edited will have the issue resolved at the time of the edit, but un-edited pages will have to wait for that 8 week process to catch up to them

debt closed this task as Resolved.Mar 21 2019, 7:16 PM