Page MenuHomePhabricator

prometheus-node-exporter makes puppet fail because requiring a version that no longer exists on buster
Closed, ResolvedPublic

Description

Not a highly critical issue, and probably should be waited until near buster is releases to hardcode the right one, so it doesn't break again.

<godog> for the node-exporter upgrade goal we're enforcing a particular version via puppet
<godog> though that version doesn't exist anymore in buster: 0.17.0+ds-3 vs 0.17.0+ds-3+b10
<godog> and apt/puppet don't really know that installing the latter version would also satisfy

Filing mostly to track puppet breakage/icinga alert at db1114 (testing buster there).

Event Timeline

jcrespo triaged this task as Low priority.Mar 12 2019, 4:03 PM
jcrespo created this task.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 12 2019, 4:03 PM