Page MenuHomePhabricator

Create Wikisource Hindi
Closed, ResolvedPublic

Description

The language committee has approved the creation of Wikisource Hindi.

  • Request page: https://meta.wikimedia.org/wiki/Requests_for_new_languages/Wikisource_Hindi
  • Language code: hi
  • Site URL: hi.wikisource.org
  • Project name: विकिस्रोत
  • Project namespace: विकिस्रोत
  • Project talk namespace: विकिस्रोत वार्ता
  • Project logo: File:Wikisource-logo-hi.png
  • Timezone: Asia/Kolkata
  • Local file uploads: disabled
  • Additional namespaces: "पृष्ठ" (Page), "पृष्ठ वार्ता" (Page Talk), "लेखक" (Author), "लेखक वार्ता" (Author Talk), "विषयसूची" (Index), "विषयसूची वार्ता" (Index Talk), "अनुवाद" (Translation), "अनुवाद वार्ता" (Translation Talk)

Thank you. (I'm quite aware that we're in a holding pattern here.)

Details

Related Gerrit Patches:
mediawiki/extensions/ProofreadPage : masterAdds namespaces translation for Hindi
operations/mediawiki-config : masterAdd hiwikisource to wikiversions.json
operations/mediawiki-config : masterAdd hiwikisource to wikidataclient.dblist
operations/mediawiki-config : masterInitial configuration for hiwikisource
analytics/refinery : masterwhitelist: add hi.wikisource
mediawiki/services/restbase/deploy : mastervars: add hi.wikisource

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes

Change 498317 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Initial configuration for hiwikisource

https://gerrit.wikimedia.org/r/498317

Urbanecm removed Urbanecm as the assignee of this task.Mar 22 2019, 8:13 AM

Should be done.

Just one small clarification wgTranslateNumerals = by 'default' => true, so during importing content from mul.wikisource, all Page: namespace need to be convert Indic Hindi numerical , like https://wikisource.org/wiki/Page:कपालकुण्डला.djvu/3 should https://hi.wikisource.org/wiki/Page:कपालकुण्डला.djvu/३ at new domain.

Urbanecm triaged this task as Low priority.Mar 24 2019, 9:43 PM
Ladsgroup added a subscriber: Ladsgroup.

I will make the new wikis.

Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptMar 26 2019, 10:34 AM

Change 499457 had a related patch set uploaded (by MarcoAurelio; owner: MarcoAurelio):
[mediawiki/services/restbase/deploy@master] vars: add hi.wikisource

https://gerrit.wikimedia.org/r/499457

If someone makes the WikimediaMessages step I can review/merge it.

Also, being a Wikisource, make sure we have ProofreadPage translations into Hindi, including special page names and aliases. Thank you.

Change 499462 had a related patch set uploaded (by MarcoAurelio; owner: MarcoAurelio):
[analytics/refinery@master] [DNM] whitelist: add hi.wikisource

https://gerrit.wikimedia.org/r/499462

Change 499457 merged by Mobrovac:
[mediawiki/services/restbase/deploy@master] vars: add hi.wikisource

https://gerrit.wikimedia.org/r/499457

Per docs, ops must be notified. I've been doing so emailing the ops list every time. I'll add the tag this time hoping this is enough.

Per docs, ops must be notified. I've been doing so emailing the ops list every time. I'll add the tag this time hoping this is enough.

Just sent an email.

Change 499462 abandoned by Nuria:
whitelist: add hi.wikisource

Reason:
...

https://gerrit.wikimedia.org/r/499462

Change 499462 restored by Nuria:
whitelist: add hi.wikisource

Reason:
sorry about my unintended last click...

https://gerrit.wikimedia.org/r/499462

Yann added a subscriber: Yann.Apr 14 2019, 8:32 AM
Yann added a comment.EditedApr 14 2019, 8:37 AM

Can we move forward here? What are the blocking issues, if any? I would like to raise the priority.

Hi @Yann, we experienced some major problems with the script we use to create new wikis. We would like to know the root cause of thoose isues before we decide to try to create other wikis. Raising priority is not possible, priority field should reflect the reality, not wishes. Due to complexity of new wiki creation, new wiki tasks are generally low priority. Ping @Ladsgroup, as he experienced those major issues. Can you please confirm/deny what I said?

Hi @Yann, we experienced some major problems with the script we use to create new wikis. We would like to know the root cause of thoose isues before we decide to try to create other wikis. Raising priority is not possible, priority field should reflect the reality, not wishes. Due to complexity of new wiki creation, new wiki tasks are generally low priority. Ping @Ladsgroup, as he experienced those major issues. Can you please confirm/deny what I said?

Yes, that's true. I will give these another try next week but first we need to make sure this doesn't cause issues.

Meno25 added a subscriber: Meno25.Apr 30 2019, 1:10 PM
Ladsgroup removed Ladsgroup as the assignee of this task.May 8 2019, 11:24 AM

The issue still exists and it's impossible to make new wikis without lots of bandage and hacks. I'm doing this in volunteer capacity and I don't have time to do it anymore :(

Ankry added a subscriber: Ankry.Jun 2 2019, 8:56 PM

@Ladsgroup Are thre any tickets describing what are the script problems that this task should depend on?

@Ladsgroup Are thre any tickets describing what are the script problems that this task should depend on?

I explained in-depth in T210752#5167695

Is there a proposed timeline on this and T210752? Is there information I need to get from the contributor communities to help move this along?

@StevenJ81 Hi, all wiki creations are blocked on T212881. That's a technical problem, and a wiki cannot be technically created.

Change 499462 merged by Nuria:
[analytics/refinery@master] whitelist: add hi.wikisource

https://gerrit.wikimedia.org/r/499462

The fix got merged, I will try this later tomorrow.

Change 498317 merged by jenkins-bot:
[operations/mediawiki-config@master] Initial configuration for hiwikisource

https://gerrit.wikimedia.org/r/498317

Change 537700 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[operations/mediawiki-config@master] Add hiwikisource to wikidataclient.dblist

https://gerrit.wikimedia.org/r/537700

Change 537700 merged by jenkins-bot:
[operations/mediawiki-config@master] Add hiwikisource to wikidataclient.dblist

https://gerrit.wikimedia.org/r/537700

Change 537701 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[operations/mediawiki-config@master] Add hiwikisource to wikiversions.json

https://gerrit.wikimedia.org/r/537701

Change 537701 merged by jenkins-bot:
[operations/mediawiki-config@master] Add hiwikisource to wikiversions.json

https://gerrit.wikimedia.org/r/537701

Mentioned in SAL (#wikimedia-operations) [2019-09-18T17:33:33Z] <Amir1> mwscript maintenance/createAndPromote.php --wiki=hiwikisource --force --sysop Ladsgroup (T218155)

Mentioned in SAL (#wikimedia-operations) [2019-09-18T17:38:40Z] <Amir1> manual write on hiwikisource "wikiadmin@10.64.0.205(hiwikisource)> update text set old_text = 'DB://cluster25/1';" (T218155)

Mentioned in SAL (#wikimedia-operations) [2019-09-18T17:40:41Z] <ladsgroup@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Add hiwikisource (T218155) (duration: 01m 04s)

Mentioned in SAL (#wikimedia-operations) [2019-09-18T17:43:16Z] <ladsgroup@deploy1001> Synchronized wmf-config/VariantSettings.php: Add hiwikisource (T218155) (duration: 01m 05s)

Mentioned in SAL (#wikimedia-operations) [2019-09-18T17:45:58Z] <ladsgroup@deploy1001> Synchronized static/images/project-logos/: Add hiwikisource logos (T218155) (duration: 01m 04s)

Ladsgroup closed this task as Resolved.Sep 18 2019, 5:52 PM

It should be okay now. For adding support to Wikidata, please open another ticket and add Wikidata. We will handle it.

Yann added a comment.Sep 18 2019, 6:00 PM

Great! Thanks a lot to all who helped!

StevenJ81 added subscribers: MF-Warburg, jhsoby.EditedSep 18 2019, 6:45 PM

Did anyone ping @MF-Warburg or @jhsoby and ask them to start copying content into this wiki? And is this task properly closed until that happens?

As a note for the future, the Main Page should remain as-is with the warning to wait to edit until importing has taken place. It should probably be reverted right now.

I am aware of this. that's what we have the newprojects mailing list for.

StevenJ81 <no-reply@phabricator.wikimedia.org> schrieb am Mi., 18. Sep.
2019, 20:45:

StevenJ81 added subscribers: MF-Warburg, jhsoby.
StevenJ81 added a comment. View Task
https://phabricator.wikimedia.org/T218155
Did anyone ping @MF-Warburg
https://phabricator.wikimedia.org/p/MF-Warburg/ or @jhsoby
https://phabricator.wikimedia.org/p/jhsoby/ and ask them to start
copying content into this wiki?
*TASK DETAIL*
https://phabricator.wikimedia.org/T218155
*EMAIL PREFERENCES*
https://phabricator.wikimedia.org/settings/panel/emailpreferences/
*To: *Ladsgroup, StevenJ81
*Cc: *jhsoby, MF-Warburg, Pharos, jeremyb, Krenair, Ankry, Meno25, Yann,
MarcoAurelio, Ladsgroup, Urbanecm, jayantanth, Koavf, SatyamMishra,
Liuxinyu970226, Aklapper, StevenJ81, Hook696, Daryl-TTMG, RomaAmorRoma,
0010318400, E.S.A-Sheild, Dibya, Meekrab2012, joker88john, Legado_Shulgin,
94rain, DannyS712, CucyNoiD, NebulousIris, thifranc, Guilhermebm, AndyTan,
Gaboe420, Jony, Versusxo, Majesticalreaper22, Giuliamocci, Davinaclare77,
Adrian1985, Qtn1293, Cpaulf30, Techguru.pc, Af420, JunaidHafeez,
BJ6123C7BTD, Darkminds3113, Bsandipan, Lordiis, Adik2382, Jayprakash12345,
Th3d3v1ls, Hfbn0, Ramalepe, Liugev6, Zoranzoki21, WSH1906, Lewizho99,
Zppix, Maathavan, DatGuy, Devwaker, Niklitov, Vikoula5, JEumerus,
Ananthsubray, Tulsi_Bhagat, Wong128hk, Luke081515, SimmeD, Snowolf, Dcljr,
Ebe123, faidon, Rschen7754, Jdforrester-WMF, Matanya, Mbch331, Rxy, Jay8g,
fgiunchedi

OK. Thanks, MF-W. As far as I can tell, the Wiki wasn't even created with the customary warning page up front. But I'll let others sort that out.

As a note for the future, the Main Page should remain as-is with the warning to wait to edit until importing has taken place. It should probably be reverted right now.

We know, but that was exactly the issue this time. The wiki creation magic created main page in a way that caused fatal error upon viewing. Hence, it was deleted server-side and re-created with some content.

OK. Thanks, MF-W. As far as I can tell, the Wiki wasn't even created with the customary warning page up front. But I'll let others sort that out.

Yup, that part is broken :).

The "classic" main page is in place.

Could you please anyone import all the pages (ns:0)/Index files/Pages?

Could you please anyone import all the pages (ns:0)/Index files/Pages?

@MF-Warburg or @jhsoby should do it as I know, right?

Ankry added a comment.EditedSep 19 2019, 5:57 PM

Could you please anyone import all the pages (ns:0)/Index files/Pages?

Importing Index files is not a good Idea, as they are generally internally localized. They should be recreated from scratch, IMO. But first, ProofredPage should be configured, at least:

  • MediaWiki:Proofreadpage index template
  • MediaWiki:Proofreadpage pagenum template

and possibly

  • MediaWiki:Proofreadpage index data config
  • MediaWiki:Proofreadpage header template

should be created.
(there are few other configuration pages, but they are not critical)
And admin/global interface editor or steward rights are needed to do this.

Maybe, a Hindi speaking user should get admin rights for this to create the pages properly localized?

Could you please anyone import all the pages (ns:0)/Index files/Pages?

@MF-Warburg or @jhsoby should do it as I know, right?

I'm not sure why people think of Jhs, as he did not volunteer "in general" by being in the new wikis importer group ;) but I have already planned to do this.

I thought he might be in training to join ... ;)

Koavf added a comment.Sep 19 2019, 7:22 PM

Just one small clarification wgTranslateNumerals = by 'default' => true, so during importing content from mul.wikisource, all Page: namespace need to be convert Indic Hindi numerical , like https://wikisource.org/wiki/Page:कपालकुण्डला.djvu/3 should https://hi.wikisource.org/wiki/Page:कपालकुण्डला.djvu/३ at new domain.

I just changed that page's language: https://wikisource.org/w/index.php?title=Special:Log&page=Page%3A%E0%A4%95%E0%A4%AA%E0%A4%BE%E0%A4%B2%E0%A4%95%E0%A5%81%E0%A4%A3%E0%A5%8D%E0%A4%A1%E0%A4%B2%E0%A4%BE.djvu%2F3 Is there value or need in doing this for other Hindi pages?

Could you please anyone import all the pages (ns:0)/Index files/Pages?

Importing Index files is not a good Idea, as they are generally internally localized. They should be recreated from scratch, IMO. But first, ProofredPage should be configured, at least:

  • MediaWiki:Proofreadpage index template
  • MediaWiki:Proofreadpage pagenum template

and possibly

  • MediaWiki:Proofreadpage index data config
  • MediaWiki:Proofreadpage header template

should be created.
(there are few other configuration pages, but they are not critical)
And admin/global interface editor or steward rights are needed to do this.
Maybe, a Hindi speaking user should get admin rights for this to create the pages properly localized?

Thanks @Ankry for your comments. Presently there are 28,307 Page: and 40+ associate Index files. So are you advice to do this again start from scratch ?

I can do this all configuration if I have interface admin access.

Change 538229 had a related patch set uploaded (by Tpt; owner: Tpt):
[mediawiki/extensions/ProofreadPage@master] Adds namespaces translation for Hindi

https://gerrit.wikimedia.org/r/538229

Thanks @Ankry for your comments. Presently there are 28,307 Page: and 40+ associate Index files. So are you advice to do this again start from scratch ?
I can do this all configuration if I have interface admin access.

Ankry is only talking about the index pages, not the page pages (hehe). However, there shouldn't be any problem importing the index pages. We did that for the Neapolitan Wikisource, and it worked just like it should. As long as the parameter names used in [[MediaWiki:Proofreadpage index template]] stay the same, the index pages will work when imported. If you want to we can translate the parameter names, but there is basically no advantage to doing so, since those will never normally be read or used by humans. Doing so would also require changing the index page code while importing, and I think it's an unnecessary complication.

Ankry added a comment.EditedSep 20 2019, 11:46 AM

Thanks @Ankry for your comments. Presently there are 28,307 Page: and 40+ associate Index files. So are you advice to do this again start from scratch ?
I can do this all configuration if I have interface admin access.

Ankry is only talking about the index pages, not the page pages (hehe). However, there shouldn't be any problem importing the index pages. We did that for the Neapolitan Wikisource, and it worked just like it should. As long as the parameter names used in [[MediaWiki:Proofreadpage index template]] stay the same, the index pages will work when imported. If you want to we can translate the parameter names, but there is basically no advantage to doing so, since those will never normally be read or used by humans. Doing so would also require changing the index page code while importing, and I think it's an unnecessary complication.

Yes, but in the default Index configuration field names are in Hindi:
https://hi.wikisource.org/w/api.php?action=query&prop=revisions&titles=Index:Test.pdf&rvslots=*&rvprop=timestamp|user|content&format=xml
While in mul.ws they are in English:
https://wikisource.org/w/api.php?action=query&prop=revisions&titles=Index:%E0%A4%B0%E0%A4%BE%E0%A4%AE%E0%A4%9A%E0%A4%B0%E0%A4%BF%E0%A4%A4%20%E0%A4%AE%E0%A4%BE%E0%A4%A8%E0%A4%B8%20%E0%A4%B0%E0%A4%BE%E0%A4%AE%E0%A4%A8%E0%A4%B0%E0%A5%87%E0%A4%B6%20%E0%A4%A4%E0%A5%8D%E0%A4%B0%E0%A4%BF%E0%A4%AA%E0%A4%BE%E0%A4%A0%E0%A5%80.pdf&rvslots=*&rvprop=timestamp|user|content&format=xml
Yes, if we copy Index configuration from mul.ws to hi.ws, import should work (the "Language" field is rather not needed in hi.ws, but this is not a problem). And this should be done prior to importing indexes.

Later changing the internal field names (to Hindi, as they are in the initial configuration) may be a pain, however. If it is ever intended.

Later changing the internal field names (to Hindi, as they are in the initial configuration) may be a pain, however. If it is ever intended.

It is easily done with a bot, luckily, I have done it before. :-)

Change 538229 merged by jenkins-bot:
[mediawiki/extensions/ProofreadPage@master] Adds namespaces translation for Hindi

https://gerrit.wikimedia.org/r/538229

Dcljr added a subscriber: Dcljr.Sep 26 2019, 7:19 AM

I have already planned to do this.

Is there any technical issue preventing importing at this point, or have you just not gotten around to it yet? (trying to ask this in the nicest way ;)

I just ask because a week's delay between wiki creation and announcement of same at Incubator:Site_creation_log (along with notice of impending importing) usually indicates something has gone wrong…

We are waiting for T233365 to be resolved.

We are waiting for T233365 to be resolved.

Already was done, just no one closed it. Fixed :)

Dcljr added a comment.Oct 5 2019, 3:59 AM

@MF-Warburg and @jhsoby: another week has passed and nothing has been imported beyond a test page by Jon. Is there some other reason for the delay besides T233365, which was resolved? Was some problem revealed when the test page was imported?

I am holding off announcing the opening of the wiki at m:Wikimedia_News until importing is done. And even though the wiki's Main Page warns users not to edit the wiki, that has not stopped users from creating pages there (I don't know if any of them will be overwritten when importing is done).

(I have not opened a separate task about this because I assume that would not actually help.)

@Dcljr: no pages will be overwritten when importing is done because all are new. We are already keeping this thing in mind. We waited for a week but nothing was happening. We don't know what's going on? What is still required to import pages? It's hard to wait so we started creating pages. It's almost three weeks and we don't have even basic proofreading templates and codes. It's really frustrating and disappointing.

I have imported all Hindi-specific pages now (everything that was in the Hindi category on mulwikisource). What remains are templates that are used by several languages in mulwikisource (such as {{rh}}), and any pages that may be missing from the category. Thanks to T234892, local administrators (when the wiki gets some) can use Special:Import to import any missing templates and other pages as needed. I have also applied for temporary bot status for my bot in order to move the imported pages in the page namespace from Latin numerals to Hindi numerals.

Pharos removed a subscriber: Pharos.Oct 8 2019, 12:51 PM

@jhsoby, is this finished yet? I'm just looking to see if (a) I should clear the task identifier from the "closed" section of Meta:Requests for new languages, and (b) I should mark the importation on Incubator's Site creation log as complete or still in progress.

The import is done as far as I can tell. There may be a few remnant pages that were not categorized properly, but I think we've caught most of those as well. The site creation log seems to be done, I'll fix the RFL thing now.