Page MenuHomePhabricator

[Bug] Sporadic 503 errors when editing
Closed, InvalidPublic

Description

Steps to reproduce

  1. Visit https://www.mediawiki.org/w/index.php?title=Reading/Web/Chores&veaction=editsource anonymously or logged in
  2. An HTTP 503 error dialog appears.

The failed request is https://www.mediawiki.org/w/api.php?action=visualeditor&format=json&paction=wikitext&page=Reading%2FWeb%2FChores&uselang=en:

Request from 73.181.4.128 via cp1083 cp1083, Varnish XID 767017918
Error: 503, Backend fetch failed at Wed, 13 Mar 2019 20:15:52 GMT

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 13 2019, 8:18 PM

Problem confirmed on Simple English Wikipedia. HTTP 503 errors and "Server response empty" errors.

Kb03 added a subscriber: Kb03.Mar 13 2019, 8:24 PM

Confirmed on Enwiki, errored out while tagging a page with Twinkle

@Jdlrobson What work / by whom is this tracking, and are they aware of that?

I dont know anything about the action=visualeditor. Am hoping editing do (its tagged VisualEditor but I assume awaiting triage). Am guessing it will also be useful to tag services too.

Can this be resolved?

I can no longer reproduce the issue reported so closing works for me. However, I'm unsure if there's additional work needed by VisualEditor.

mobrovac closed this task as Invalid.Mar 19 2019, 8:10 PM

I dont know anything about the action=visualeditor.

The error text in this report is from a Varnish-generated error page (the white page with the foundation logo etc.).

For future reference, in our stack an HTTP 503 Backend fetch failed, can only come from intermediary layers in front of MediaWiki, not MW itself (e.g. CGI, FPM, Apache, Varnish backend etc.). So this'd be an issue for Traffic in that case.