Page MenuHomePhabricator

Wikimedia maps cannot support language fallback
Closed, ResolvedPublic

Description

Related Objects

Event Timeline

C933103 created this task.Mar 15 2019, 8:01 PM
Restricted Application added subscribers: Cosine02, Aklapper. · View Herald TranscriptMar 15 2019, 8:01 PM
Pikne added a subscriber: Pikne.Mar 18 2019, 8:22 AM

There is a fallback mechanism in place. Relevant fallbacks are described here. The problem seems to be that "zh" and its variants generally fall back to "zh-hans" that is little used on OSM (see taginfo). I assume these fallbacks should be rearranged, as long as Wikimedia maps localization relies on OSM tags.

Additionally the language picker is bugous, so that some languages that shouldn't be latinized get latinized (see T208927).

Is the system case-sensitive? Because the document use "zh-hans" and "zh-hant" while relevant keys in OSM are usually "zh-Hans" and "zh-Hant"

MSantos triaged this task as Low priority.Mar 19 2019, 3:19 PM
Liuxinyu970226 added a subscriber: Liuxinyu970226.EditedMar 21 2019, 5:17 AM

@C933103 and @Pikne Why this is a Language-strategy task? Comparing with task description, I'm not sure if we really need to "fix this problem" in all languages (or at least a batch of languages that ≥50) or not.

There were definitely >100 languages affected if language fallback didn't work in all languages, but if it's only for those that fallback to zh, and a few other languages that utilize script tag in Mediawiki project but utilize an alternative language tagging style in OSM projects, then the scope of the task could have been smaller than anticipated.

Pikne closed this task as Resolved.Wed, Aug 7, 1:23 PM
Pikne removed a project: Language-strategy.

I'm closing this as Chinese fallbacks were improved in a pull request. Please reopen if it doesn't work as intended.

Shizhao moved this task from Backlog to Closed on the Chinese-Sites board.Fri, Aug 9, 2:49 AM