Page MenuHomePhabricator

Score extension now leaving large amounts of space on rendering
Closed, ResolvedPublic

Description

Recently new scores using the score snippet are rendering with large amounts of white space. For an example, see this enWS page I worked on a few minutes ago. This would appear to be due to the latest MW release, because this page was initially rendered a few days ago and it doesn't show the problem.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 18 2019, 5:10 AM
mb added a subscriber: mb.Mar 18 2019, 11:53 AM

A baffling example can be seen at en:Help talk:Score#Image size.

TheDJ added a subscriber: TheDJ.EditedMar 18 2019, 9:01 PM

The generated image is way too large and the source of the whitespace

<img src="//upload.wikimedia.org/score/f/v/fvl2i875c7j113z7vqcfbpje3kswti6/fvl2i875.png" width="835" height="1181" alt="{c' d' e' f' f' fes' eis' f'}">

Bonvol added a subscriber: Bonvol.Mar 18 2019, 9:22 PM

More thorough description:

Polish Wikisource users reported recent problems with rendering of newly transcribed notes (Extension:Score). I compared "old" transcripts (with last change within <score> tags more than several weeks) and a "new" transcript. The issue is reproduceable.

Steps to Reproduce:
Scenario 1 (regression bug - show that pages rendered correctly earlier are broken after any changes)

Pick any page that uses Score extension without any recent changes. Example: https://pl.wikisource.org/wiki/Strona:PL_Roger_-_Pieśni_Ludu_Polskiego_w_Górnym_Szląsku.djvu/44. This is the respective .png rendered for this score: https://upload.wikimedia.org/score/d/q/dq6kxl0muwambka4wk07y9xnvr6em88/dq6kxl0m.png
Edit the page. Change any note within <score> tag to force rerendering and pick "Show preview" instead of saving.
Scenario 2

Check the rendering of any newly created page using Score extension. Example: https://pl.wikisource.org/wiki/Strona:PL_Roger_-_Pieśni_Ludu_Polskiego_w_Górnym_Szląsku.djvu/241 (rendered .png: https://upload.wikimedia.org/score/6/c/6c428f0gjrqkgc6blrlu6p6dfetm00g/6c428f0g.png )

Actual Results:
Scenario 1:
The score will be rendered as a full page .png which is incorrect as it leaves too much space between the score and MIDI player and the subsequent text on the page.
Scenario 2:
The same as in scenario 1: score is rendered as a whole page that results in a large gap between the score and the text below and MIDI player (visible on wikisource page)

Expected Results:
Scenario 1:
Score should resemble "old" layout, its size should be adequate to the length of the score, rerendering should only include changed note and not change the whole layout
Scenario 2:
As in scenario 1: the .png should be large enough to fit the score, but not larger

Ankry added a subscriber: Ankry.Mar 18 2019, 10:15 PM
Ebe123 added a subscriber: Ebe123.Mar 19 2019, 12:31 AM

The problem is that ImageMagick, the program used to crop the scores, is not working. However, how ImageMagick is called has not changed in a while...

Shoot, I thought I had posted this in the morning!

Change 497433 had a related patch set uploaded (by Ebe123; owner: Ebe123):
[operations/mediawiki-config@master] Partially revert "Enable musical notation datatype in wikidata"

https://gerrit.wikimedia.org/r/497433

Will be fixed with T218643

Addshore triaged this task as High priority.Mar 19 2019, 9:40 AM
Restricted Application added a project: Wikidata. · View Herald TranscriptMar 19 2019, 1:44 PM

@Ebe123 was this deployed in yesterday's swat?

Change 497433 had a related patch set uploaded (by Ladsgroup; owner: Ebe123):
[operations/mediawiki-config@master] Partially revert "Enable musical notation datatype in wikidata"

https://gerrit.wikimedia.org/r/497433

Change 497433 merged by jenkins-bot:
[operations/mediawiki-config@master] Partially revert "Enable musical notation datatype in wikidata"

https://gerrit.wikimedia.org/r/497433

Mentioned in SAL (#wikimedia-operations) [2019-03-20T11:28:30Z] <ladsgroup@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:497433|Partially revert "Enable musical notation datatype in wikidata" (T218535)]] (duration: 00m 50s)

alaa_wmde closed this task as Resolved.Mar 20 2019, 11:32 AM
alaa_wmde claimed this task.
alaa_wmde added a comment.EditedMar 20 2019, 12:03 PM

Oops sorry resolve it by mistake .. meant to resolve only the other one.. thanks for fixing Lydia

Ebe123 closed this task as Resolved.Mar 20 2019, 12:10 PM
Ebe123 added a subscriber: Lydia_Pintscher.

@Lydia_Pintscher, why would a bug-fix for a bug that never affected Wikidata need to be announced there?

Ankry added a comment.EditedMar 20 2019, 1:01 PM

I think, this still needs some maintenance to regenerate broken score images, created while the wrong configuration was active.

Impossible to have a full list of broken scores, but they can be fixed by adding a comment to the scores, which will force regeneration.

@Ebe123 This is handled by the Wikidata team and the Wikidata team has a specific process about how tickets flow through the pipeline. A part of that is product management and community communications testing the feature or bugfix to make sure everything is ok. So please leave the ticket open when someone reopens it when their team is the one working on it.

Ankry added a comment.Mar 20 2019, 3:52 PM

Impossible to have a full list of broken scores, but they can be fixed by adding a comment to the scores, which will force regeneration.

No true. This is possible. Only pages with the "score" property edited in specific time period are affected and number of wikis that use score effectively is limited. Basing on such a query:
https://quarry.wmflabs.org/query/34588
I can likely provide a full list of broken score images.

Will it be helpful?

@Lydia_Pintscher: I understand that you have your processes, that was not the concern. It was more asking why Wikidata has taken an interest in this bug, seeing that it did not affect Wikidata (some sort of taking responsibility as the cause of the bug?)

@Ankry: It would be helpful, thanks! I didn't know about this quarry-ing :) Would be good to group by page, but also make sure that content in the score tag was modified in the timeframe, and include all wikis)

@Lydia_Pintscher: I understand that you have your processes, that was not the concern. It was more asking why Wikidata has taken an interest in this bug, seeing that it did not affect Wikidata (some sort of taking responsibility as the cause of the bug?)

Yes. It was caused in the process of enabling showing of musical notations in Wikidata statements.

Impossible to have a full list of broken scores, but they can be fixed by adding a comment to the scores, which will force regeneration.

No true. This is possible. Only pages with the "score" property edited in specific time period are affected and number of wikis that use score effectively is limited. Basing on such a query:
https://quarry.wmflabs.org/query/34588
I can likely provide a full list of broken score images.
Will it be helpful?

I would rather deal with my five scores on enWS myself. Even if a bot amends them, I'll still have to go back into the pages to do other tasks. I would be surprised if there were any other enWS scores affected as I'm the principal editor of such and I would have been contacted by anyone else seeing the problem.

Ankry added a comment.Mar 20 2019, 7:38 PM

@Ankry: It would be helpful, thanks! I didn't know about this quarry-ing :) Would be good to group by page, but also make sure that content in the score tag was modified in the timeframe, and include all wikis)

Here is the list of broken images generated among wikis:

https://upload.wikimedia.org/score/0/c/0c08miik3ab0im9znd4fpht1t8k2ksg/0c08miik.png
https://upload.wikimedia.org/score/0/t/0tm5ftrzecrif7tsbneqfeox3fthsuq/0tm5ftrz.png
https://upload.wikimedia.org/score/0/x/0xc2cm406w3iczen70qmxd7ahtq3rei/0xc2cm40.png
https://upload.wikimedia.org/score/2/j/2jshumqin2u4bm0nfbvi0ooaiaau6ez/2jshumqi.png
https://upload.wikimedia.org/score/5/o/5ovgf15ixvqouua9jzm4u8cxl0gx7m4/5ovgf15i.png
https://upload.wikimedia.org/score/6/1/61t9ds9rngue4hhen5mngedfsy351tl/61t9ds9r.png
https://upload.wikimedia.org/score/6/a/6a5fket5ul4ltminkt4k4woy2qnljbc/6a5fket5.png
https://upload.wikimedia.org/score/7/f/7f68f6qowskkxolinek0o684huy21qk/7f68f6qo.png
https://upload.wikimedia.org/score/b/0/b0md3i5azyii6jtxlvt7cszgtnspwsh/b0md3i5a.png
https://upload.wikimedia.org/score/b/2/b2uin36trvg1xk2tuza8j6zkrz4ps05/b2uin36t.png
https://upload.wikimedia.org/score/b/o/bo41q8bb8rx29hkk9is390q5acltnq0/bo41q8bb.png
https://upload.wikimedia.org/score/d/b/dbcvn3ce2az56ynqr8itliq69xrbk5d/dbcvn3ce.png
https://upload.wikimedia.org/score/d/f/df9m7e7tc53i81cs1dfr62ynufaz2cq/df9m7e7t.png
https://upload.wikimedia.org/score/d/h/dh0h5zy60mgao1h01dlzcjgusjspukb/dh0h5zy6.png
https://upload.wikimedia.org/score/d/n/dnxu7ypvt2ueygia95k6gngu9l8f6q0/dnxu7ypv.png
https://upload.wikimedia.org/score/e/9/e9rdlqnrh55hnwcjmfdgf5ssy51uf4y/e9rdlqnr.png
https://upload.wikimedia.org/score/e/c/ecbivx5igjrjbb62e7oidgg1yyjbyyp/ecbivx5i.png
https://upload.wikimedia.org/score/f/v/fvl2i875c7j113z7vqcfbpje3kswti6/fvl2i875.png
https://upload.wikimedia.org/score/g/9/g9w1cpzc34jth7ib21dgsjajmpilm0c/g9w1cpzc.png
https://upload.wikimedia.org/score/g/b/gb0avdsjobszo6m2dk4j9hzyu126hks/gb0avdsj.png
https://upload.wikimedia.org/score/g/k/gktf12z2zu2oqwpumd2s2cczb3mrofb/gktf12z2.png
https://upload.wikimedia.org/score/g/l/gl963qrj8ozb3y8z1thmzoarkvx1g9l/gl963qrj.png
https://upload.wikimedia.org/score/j/4/j4j5gu21rby7jbkgw4hrc64ke24lafu/j4j5gu21.png
https://upload.wikimedia.org/score/k/8/k86qbqqadl6vcnyczt9u48i2g9jh2wx/k86qbqqa.png
https://upload.wikimedia.org/score/k/o/koz9is172vxe7k2rm5a05x12jsi3bmw/koz9is17.png
https://upload.wikimedia.org/score/l/t/ltxlb7y7w1csuwoy0wzjmdzuxf3agm0/ltxlb7y7.png
https://upload.wikimedia.org/score/m/2/m2ebyunggl7k94nkc2598boexjjc8qf/m2ebyung.png
https://upload.wikimedia.org/score/m/r/mr62oxjzp0ck5i7rfjwprinlp7umn9q/mr62oxjz.png
https://upload.wikimedia.org/score/o/n/onuawf5ssugr07zrmd9htrzvkpkvpxh/onuawf5s.png
https://upload.wikimedia.org/score/o/x/ox71l165koevcuqcy0rv6fki0ndsmws/ox71l165.png
https://upload.wikimedia.org/score/o/y/oy1791by26zvua6mpeuan1m8g9oe2f8/oy1791by.png
https://upload.wikimedia.org/score/p/9/p922atp5yzg3ltaaklug4ca94mxn2e2/p922atp5.png
https://upload.wikimedia.org/score/p/t/ptitucpdhhl5jir8tnqfy9j0g3o6ldj/ptitucpd.png
https://upload.wikimedia.org/score/r/g/rgcbfun7pa76k7gsiu8qwdtulwo8tcv/rgcbfun7.png
https://upload.wikimedia.org/score/r/u/ruj2euqdmhevh7dyll4nn1cmlnty8b3/ruj2euqd.png

Ankry added a comment.Mar 20 2019, 7:47 PM

I would rather deal with my five scores on enWS myself. Even if a bot amends them, I'll still have to go back into the pages to do other tasks. I would be surprised if there were any other enWS scores affected as I'm the principal editor of such and I would have been contacted by anyone else seeing the problem.

I confirm: 5 from enwikisource, 8 from plwikisource; others distributed among various wikipedias