Page MenuHomePhabricator

Structured fields don't show a notice about IP logging for users who aren't logged in
Closed, ResolvedPublicFeature

Description

User story: N/A

We have this:

We show users a notification about CC0 licensing and the terms of use when they first edit/add structured data, but we don't explicitly say anything about IP logging, like we do with wikitext.

Wikidata accomplishes this with a small alert popover:

We want this:

A way to notify users about IP logging, positioned in the top center of the screen, per the visual styling guidance provided on M241

Screenshots (if possible):

  • Background color: #FEF6E7
  • Icon color: #FFCC33
  • OOUI icon label: "alert"
  • Note: link should _underline_ upon hover

Acceptance Criteria:

QA Results

ACStatusDetails
1โœ…T218628#5071464
2โœ…T218628#5071464
3โœ…T218628#5071464
4โŒT218628#5071464

Details

Related Gerrit Patches:
mediawiki/extensions/WikibaseMediaInfo : masterFollow-up I3c037a8bd, Iaeaae3ded: Parse `anoneditwarning` server-side
mediawiki/extensions/WikibaseMediaInfo : masterFollow-up I3c037a8bd: Parse `anoneditwarning`; it contains rich content
mediawiki/extensions/WikibaseMediaInfo : masterWarn anonymous editing users that their IP will be logged

Event Timeline

Restricted Application added a subscriber: Aklapper. ยท View Herald TranscriptMar 19 2019, 1:09 AM
Ramsey-WMF changed the subtype of this task from "Bug Report" to "Feature Request".Mar 19 2019, 1:12 AM
Ramsey-WMF moved this task from Untriaged to Needs Design on the Multimedia board.
Ramsey-WMF added subscribers: Abit, Keegan.

This feature may not be necessary, but I wanted to explicitly address it before we go too much further. Thoughts, @Abit or @Keegan ? Should we get legal involved too? (fodder for our Wednesday meeting, Amanda?)

Abit added a comment.Mar 19 2019, 1:15 AM

Should we get legal involved too? (fodder for our Wednesday meeting, Amanda?)

Totes, I've added it to the Wed agenda.

Background info: we did check the way it's currently done on Wikidata with legal back then. So if you want to do the same it will probably be fine. if you'd like to do it differently then it might be a good idea o get input again.

That's a huge problem IMO. Since the product is already in production, it would be nice if it could be solved very quickly. Thanks.

PDrouin-WMF updated the task description. (Show Details)Mar 25 2019, 3:15 PM
PDrouin-WMF updated the task description. (Show Details)
PDrouin-WMF updated the task description. (Show Details)Mar 25 2019, 4:13 PM
PDrouin-WMF updated the task description. (Show Details)
Cparle claimed this task.Mar 25 2019, 4:24 PM
PDrouin-WMF updated the task description. (Show Details)Mar 25 2019, 4:29 PM
Cparle removed Cparle as the assignee of this task.Mar 25 2019, 4:50 PM
Cparle added a subscriber: Cparle.
Ramsey-WMF triaged this task as High priority.
Ramsey-WMF moved this task from To Do to Doing on the Structured-Data-Team-Current-Work board.
egardner added a comment.EditedMar 25 2019, 7:07 PM

I'm going to attempt to address this ticket using the generic mw.notification system (which seems to be what Wikibase uses anyway), so that we don't need to re-invent the wheel. I'll see if I can arrive at the desired behavior based on the options provided by this feature.

This ended up being pretty straightforward, since we can rely on existing functionality. Here's a screenshot:

There are no custom styles or other UI elements, just the default mw.notification behavior when you set the type option to warn. This is the same way Wikibase handles things.

Change 498986 had a related patch set uploaded (by Eric Gardner; owner: Eric Gardner):
[mediawiki/extensions/WikibaseMediaInfo@master] Warn anonymous editing users that their IP will be logged

https://gerrit.wikimedia.org/r/498986

Ramsey-WMF moved this task from Needs Design to Next up on the Multimedia board.Mar 26 2019, 4:21 PM

Change 498986 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Warn anonymous editing users that their IP will be logged

https://gerrit.wikimedia.org/r/498986

Change 499342 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/WikibaseMediaInfo@master] Follow-up I3c037a8bd: Parse anoneditwarning; it contains rich content

https://gerrit.wikimedia.org/r/499342

Change 499342 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Follow-up I3c037a8bd: Parse anoneditwarning; it contains rich content

https://gerrit.wikimedia.org/r/499342

Change 499556 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/WikibaseMediaInfo@master] Follow-up I3c037a8bd, Iaeaae3ded: Parse anoneditwarning server-side

https://gerrit.wikimedia.org/r/499556

Change 499556 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Follow-up I3c037a8bd, Iaeaae3ded: Parse anoneditwarning server-side

https://gerrit.wikimedia.org/r/499556

Jdforrester-WMF moved this task from Doing to Needs QA on the Structured-Data-Team-Current-Work board.

Now for QA.

Example screenshot from Beta Cluster including the deep magic template/Lua version used on production:

Edtadros added a subscriber: Edtadros.EditedMar 30 2019, 2:31 AM

Test Result

Status: โ“ Please review
OS: macOS Mojave
Browser: Chrome

Test Artifact(s):

โœ… AC1: Logged out users always see some sort of warning/notification that their IP will be logged for anonymous edits.

โœ… AC2: IP address url: https://en.wikipedia.org/wiki/IP_address

โœ… AC3: Log in url: https://commons.wikimedia.org/w/index.php?title=Special:UserLogin

โŒ AC4: Create an account url: https://commons.wikimedia.org/w/index.php?title=Special:CreateAccount
There was no link in the popover for creating an account.

Edtadros updated the task description. (Show Details)Mar 30 2019, 2:35 AM

@Jdforrester-WMF hey James, the screenshot you posted has different text than the one from Wikidata included in the description. How/why is it different?

@Jdforrester-WMF hey James, the screenshot you posted has different text than the one from Wikidata included in the description. How/why is it different?

It's using the proper text from MediaWiki, which is what Commons uses and the community has translated, not Wikidata's localised version.

It is my understanding that the text is always going to depend on the way the Wiki in question has been configured. I think this is the correct behavior, even if some sites have been configured to display text different than what we are expecting.

Given this fact, the expected behavior is working correctly on both Beta and Test commons, so I'm moving this to "verify on production".

Ok on test-commons

Ramsey-WMF closed this task as Resolved.Apr 23 2019, 9:03 PM

The engineering part of this works. We still need to update the text though, but that's a separate thing.