Page MenuHomePhabricator

Mobile visual editor scrolls to the top of the page after adding a link in iOS Safari
Closed, ResolvedPublic

Description

Mobile visual editor scrolls to the top of the page after adding a link in iOS Safari

Video: https://drive.google.com/file/d/1IUMSSelHp850K5B9xUdcIqy82uRpcvUD/view (too large for Phab)

Event Timeline

matmarex created this task.Mar 19 2019, 5:01 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 19 2019, 5:01 AM
matmarex claimed this task.Mar 19 2019, 5:01 AM
matmarex edited projects, added VisualEditor (Current work); removed VisualEditor.

Change 497450 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/MobileFrontend@master] MobileFrontendArticleTarget: Remove getScrollContainer() override

https://gerrit.wikimedia.org/r/497450

Change 497451 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[VisualEditor/VisualEditor@master] ve.ce.Surface: Stop editor scrolling to selection constantly on iOS

https://gerrit.wikimedia.org/r/497451

Change 497451 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] ve.ce.Surface: Stop editor scrolling to selection constantly on iOS

https://gerrit.wikimedia.org/r/497451

Change 498198 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (af9089ac5)

https://gerrit.wikimedia.org/r/498198

Change 498198 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (af9089ac5)

https://gerrit.wikimedia.org/r/498198

Change 497450 merged by Jdlrobson:
[mediawiki/extensions/MobileFrontend@master] MobileFrontendArticleTarget: Remove getScrollContainer() override

https://gerrit.wikimedia.org/r/497450

Ryasmeen added a subscriber: Ryasmeen.EditedMar 25 2019, 7:25 PM

@matmarex: This seems to be still happening on Beta cluster? Maybe it does not go the top most area of the article but towards the top still. Video:

@matmarex: Thoughts on this?

@Ryasmeen I think the issue we're seeing in that video is identical to T218650: In mobile VE, using the "Format" menu causes the page to scroll up by ~half the screen every time (iOS only?). Maybe we're also seeing T219200: [Regression wmf.23] Viewport sometimes jumps to the top abruptly on mobile VE. I'm pretty sure that this bug is actually fixed, and those are separate issues, but let's keep it open until we resolve them as well and can verify this.

@Ryasmeen I think the issue we're seeing in that video is identical to T218650: In mobile VE, using the "Format" menu causes the page to scroll up by ~half the screen every time (iOS only?). Maybe we're also seeing T219200: [Regression wmf.23] Viewport sometimes jumps to the top abruptly on mobile VE. I'm pretty sure that this bug is actually fixed, and those are separate issues, but let's keep it open until we resolve them as well and can verify this.

So @matmarex: with these two bugs being fixed, the issue of viewport scrolling to the top of the page after adding a link seems to be fixed now. However, there is still an issue where the added link still says out of view with the keyboard sliding up. I vaguely remember there being another task about this but can't find it. Is there any? And do you think we can close this one and track this part of the issue as a separate task?

I'm not familiar with that problem, and I don't recall any relevant tasks… I would prefer if we filed a separate task for it.

I filed T221723 and noted some details there.

ppelberg closed this task as Resolved.Jun 18 2019, 12:26 AM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJun 18 2019, 12:26 AM