Page MenuHomePhabricator

[Bug] No history button shown on server rendered page (grade C browsers)
Closed, ResolvedPublic2 Story Points

Description

Steps to reproduce

  1. Login, enable advanced mobile contributions and beta mode, and visit https://es.m.wikipedia.org/wiki/Simbolismo on the MinervaNeue mobile site with JavaScript enabled.
  2. Disable JavaScript (or emulate Opera Mini browser user agent - a grade C browser) and refresh the page.

Expected results

  • History icon should show

Actual results

  • History icon does not show

Environments observed

  • Browser version: Chromium v73.0.3683.75
  • OS version: Ubuntu v18.10
  • Device model: Desktop
  • Device language: English

Check any additional observations

Developer notes

The link is there, but the history icon is being loaded via JavaScript using skins.minerva.icons.images.variants. It should probably be also added to skins.minerva.icons.images (which avoids data-uris) to avoid impacting first paint.

QA Instructions

The goal here is to verify that the history button is visible for logged-in users in AMC mode, while using a Grade C browser, or with Javascript disabled. A list of Grade C mobile browsers are available on the Compatibility page. That's pretty much it.
Steps

  • Log in as an AMC user on the beta cluster
  • In mobile mode
  • Go to an article page ( Special:LongPages has a good list of imported wikipedia articles).
  • Disable Javascript on your browser (probably via the DevTools)
  • Verify that the history button is visible and leads to the Mobile:History page
  • Verify the above on a Grade C browser

QA Results

StatusDetails
✅ PassedT218807#5071217

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 20 2019, 5:16 PM
Jdlrobson renamed this task from [Bug] No history or download button shown on server rendered page to [Bug] No history button shown on server rendered page.Mar 20 2019, 6:10 PM
Jdlrobson moved this task from To Triage to Needs Analysis on the Readers-Web-Backlog board.
Jdlrobson updated the task description. (Show Details)
Jdlrobson added a subscriber: Jdlrobson.

The download button is by design and blocked on being able to point to Proton (T181079). As a result I've descoped this to history as I think that distinction is helpful.

Jdlrobson renamed this task from [Bug] No history button shown on server rendered page to [Bug] No history button shown on server rendered page (grade C browsers).Mar 20 2019, 6:14 PM
Jdlrobson updated the task description. (Show Details)
Jdlrobson updated the task description. (Show Details)Mar 20 2019, 6:16 PM
Jdlrobson moved this task from Needs Analysis to Triaged but Future on the Readers-Web-Backlog board.

I've looked into the clock icon usage, and even though it has a grey variant, I don't think the original black icon is actually used anywhere. However, the black version is still being loaded for the skins.minerva.icons.images.variants module.

I think we can change the fill color on the SVG to grey, then remove the grey variant from skins.minerva.icons.images.variants.

come to think of it, I don't think the profile icon in skins.minerva.icons.images.variants is being used in either it's original black or the white variant.I think if we change the profile icon to grey, we could remove the skins.minerva.icons.images.variants module entirely.

All we really need is a white variant for the clock icon, and that can be specified in skins.minerva.icons.images.

Change 498111 had a related patch set uploaded (by Jdrewniak; owner: Jdrewniak):
[mediawiki/skins/MinervaNeue@master] Remove skins.minerva.icons.images.variants module

https://gerrit.wikimedia.org/r/498111

ovasileva set the point value for this task to 2.Mar 21 2019, 5:18 PM

Change 498111 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Remove skins.minerva.icons.images.variants module

https://gerrit.wikimedia.org/r/498111

Jdrewniak updated the task description. (Show Details)Mar 26 2019, 4:44 PM
Jdrewniak reassigned this task from Jdrewniak to Edtadros.Mar 29 2019, 1:15 PM
Jdrewniak updated the task description. (Show Details)
Edtadros reassigned this task from Edtadros to ovasileva.EditedMar 29 2019, 11:36 PM
Edtadros added subscribers: ovasileva, Edtadros.

Test Result:Production

Status: ✅ PASS
OS: iOS
Browser: Safari on (iPhone XS Max)

Test Artifact(s):

Log in as an AMC user on the beta cluster
In mobile mode
Go to an article page ( Special:LongPages has a good list of imported wikipedia articles).
Disable Javascript on your browser (probably via the DevTools)
Verify that the history button is visible and leads to the Mobile:History page

Verify the above on a Grade C browser

Browser: Opera Touch on (iPhone XS Max)

@ovasileva I tried to find the Amazon Silk browser or Opera Mini specifically. The only one I found is Opera Touch. I'm not sure this is a Grade C browser. Please confirm before signoff

Edtadros updated the task description. (Show Details)Mar 29 2019, 11:38 PM
ovasileva closed this task as Resolved.Apr 8 2019, 5:10 PM

Resolving. Tested on browser without JS.