Page MenuHomePhabricator

PHP Notice: Undefined index: bits for Special:AbuseFilter/test
Closed, ResolvedPublic

Description

Error

Request ID: XJOAyApAAD0AAG4H1jwAAAAA

message
PHP Notice: Undefined index: bits
stacktrace
#0 /srv/mediawiki/php-1.33.0-wmf.22/extensions/AbuseFilter/includes/AbuseFilter.php(2899): MWExceptionHandler::handleError(integer, string, string, integer, array, array)
#1 /srv/mediawiki/php-1.33.0-wmf.22/extensions/AbuseFilter/includes/AbuseFilter.php(2791): AbuseFilter::getUploadVarsFromRCRow(stdClass)
#2 /srv/mediawiki/php-1.33.0-wmf.22/extensions/AbuseFilter/includes/Views/AbuseFilterViewTestBatch.php(187): AbuseFilter::getVarsFromRCRow(stdClass)
#3 /srv/mediawiki/php-1.33.0-wmf.22/extensions/AbuseFilter/includes/Views/AbuseFilterViewTestBatch.php(119): AbuseFilterViewTestBatch->doTest()
#4 /srv/mediawiki/php-1.33.0-wmf.22/extensions/AbuseFilter/includes/special/SpecialAbuseFilter.php(122): AbuseFilterViewTestBatch->show()
#5 /srv/mediawiki/php-1.33.0-wmf.22/includes/specialpage/SpecialPage.php(569): SpecialAbuseFilter->execute(string)
#6 /srv/mediawiki/php-1.33.0-wmf.22/includes/specialpage/SpecialPageFactory.php(558): SpecialPage->run(string)
#7 /srv/mediawiki/php-1.33.0-wmf.22/includes/MediaWiki.php(288): MediaWiki\Special\SpecialPageFactory->executePath(Title, RequestContext)
#8 /srv/mediawiki/php-1.33.0-wmf.22/includes/MediaWiki.php(867): MediaWiki->performRequest()
#9 /srv/mediawiki/php-1.33.0-wmf.22/includes/MediaWiki.php(517): MediaWiki->main()
#10 /srv/mediawiki/php-1.33.0-wmf.22/index.php(42): MediaWiki->run()
#11 /srv/mediawiki/w/index.php(3): include(string)
#12 {main}

Notes

Caused by https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/AbuseFilter/+/445325/.

Impact

Very low: the file_bits_per_channel variable is computed as the empty string for Special:AbuseFilter/test. Other variables and filter execution upon uploading itself aren't affected.

Event Timeline

Daimona created this task.Mar 21 2019, 12:47 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 21 2019, 12:47 PM
Daimona updated the task description. (Show Details)Mar 21 2019, 12:49 PM

Change 498073 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/extensions/AbuseFilter@master] Change method used for file_bits_per_channel in /test

https://gerrit.wikimedia.org/r/498073

Daimona claimed this task.Mar 21 2019, 1:08 PM

Change 498073 merged by jenkins-bot:
[mediawiki/extensions/AbuseFilter@master] Change method used for file_bits_per_channel in /test

https://gerrit.wikimedia.org/r/498073

Daimona closed this task as Resolved.Mar 22 2019, 10:34 AM
Daimona removed a project: Patch-For-Review.