Page MenuHomePhabricator

Run `git submodule sync` when updating extensions.git clones
Closed, DeclinedPublic

Description

We're getting failures due to the issues in T218844...

Can we add git submodule sync --recursive into the mix of git clone/checkout/update for the extensions.git repo?

https://git-scm.com/docs/git-submodule

sync [--recursive] [--] [<path>…​]
Synchronizes submodules' remote URL configuration setting to the value specified in .gitmodules. It will only affect those submodules which already have a URL entry in .git/config (that is the case when they are initialized or freshly added). This is useful when submodule URLs change upstream and you need to update your local repositories accordingly.

git submodule sync synchronizes all submodules while git submodule sync -- A synchronizes submodule "A" only.

If --recursive is specified, this command will recurse into the registered submodules, and sync any nested submodules within.

Related Objects

StatusAssignedTask
ResolvedDzahn
ResolvedDzahn
OpenNone
OpenNone
OpenNone
ResolvedPaladox
OpenNone
OpenNone
OpenNone
StalledNone
OpenNone
OpenPaladox
ResolvedPaladox
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
DeclinedNone

Event Timeline

Reedy created this task.Mar 21 2019, 7:00 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 21 2019, 7:00 PM
Reedy renamed this task from Run `git submodule sync` to Run `git submodule sync` when updating extensions.git clones.Mar 21 2019, 7:01 PM

CI doesn't use mediawiki/extensions.git?

Paladox moved this task from Bugs & stuff to Local hacks on the Gerrit board.Mar 22 2019, 11:18 PM
hashar closed this task as Declined.Mar 22 2019, 11:48 PM
hashar added a subscriber: hashar.

Nop CI does not use mediawiki/extensions.git . It is unclear to me what the issue is about. Feel free to reopen with more details though :)

See IRC discussion. Some of Quibble's repos are randomly still pointing at /r/p/ not /r/ so jobs are fatalling on launch.