Page MenuHomePhabricator

wikitech runJobs.php error
Closed, DuplicatePublic

Description

Fails frequently with this error:

Mar 21 19:10:01 labweb1001 systemd[1]: Started Run Wikitech runJobs.php maintenance script.
Mar 21 19:10:02 labweb1001 php[37030]: 
                                       Fatal error: Invalid operand type was used: cannot perform this operation with arrays in /srv/mediawiki/php-1.33.0-wmf.22/extensions/CirrusSearch/includes/Job/ElasticaWrite.php on line 79
Mar 21 19:10:02 labweb1001 mwscript[37026]: [Thu Mar 21 19:10:02 2019] [hphp] [37030:7f1d743233c0:0:000001] []
Mar 21 19:10:02 labweb1001 mwscript[37026]: Fatal error: Invalid operand type was used: cannot perform this operation with arrays in /srv/mediawiki/php-1.33.0-wmf.22/extensions/CirrusSearch/includes/Job/ElasticaWrite.php on line 79
Mar 21 19:10:02 labweb1001 systemd[1]: wikitech_run_jobs.service: Main process exited, code=exited, status=255/n/a
Mar 21 19:10:02 labweb1001 systemd[1]: wikitech_run_jobs.service: Unit entered failed state.
Mar 21 19:10:02 labweb1001 systemd[1]: wikitech_run_jobs.service: Failed with result 'exit-code'.
`

Server: labweb1001
Unit: wikitech_run_jobs.service
Command: /usr/local/bin/mwscript maintenance/runJobs.php --wiki=labswiki

Event Timeline

GTirloni created this task.Mar 21 2019, 7:38 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 21 2019, 7:38 PM
GTirloni triaged this task as Normal priority.Mar 21 2019, 7:38 PM
Restricted Application added a project: Discovery-Search. · View Herald TranscriptMar 21 2019, 7:48 PM
GTirloni removed a subscriber: GTirloni.Mar 21 2019, 9:10 PM
GTirloni updated the task description. (Show Details)Mar 21 2019, 11:40 PM

Mentioned in SAL (#wikimedia-operations) [2019-03-21T23:57:11Z] <gtirloni> downtimed systemd check in labweb1001/1002 (T218935)

debt closed this task as Invalid.Mar 28 2019, 5:14 PM
debt added a subscriber: debt.

closing this as a dupe of T218943

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:07 PM