Page MenuHomePhabricator

Height of header and footer of ProofreadPage reduced, cannot resize text fields in browser
Closed, InvalidPublicBug

Description

Steps to Reproduce:

  1. Open any Wikisource document in edit mode in the Page namespace. Both the header and footer are 2 text rows high instead of 3. This makes editing multi line header/footer information impossible to edit because the first row is always contains the page title.
  1. In the same edit view, it is no longer possible to elongate (expand) the <header>, <footer> and <textarea> frames by grabbing the "handle" of the lower right corner of a frame.

Actual Results:
Above features are locked

Expected Results:
A three row height window frame for the header and footer and enable the expansion of the frames.

Event Timeline

Ineuw created this task.Mar 23 2019, 2:35 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 23 2019, 2:35 AM
Aklapper changed the task status from Open to Stalled.Mar 23 2019, 8:17 AM

@Ineuw: Please provide a specific link that allows reproducing the problem, plus exact browser information. Please follow https://www.mediawiki.org/wiki/How_to_report_a_bug and also try https://www.mediawiki.org/wiki/Help:Locating_broken_scripts

Cannot reproduce the problem in Firefox 66 on Linux when going to https://en.wikisource.org/w/index.php?title=Page:Timber_and_Timber_Trees,_Native_and_Foreign.djvu/74&action=edit

For future reference, please summarize the actual issue in the task summary, otherwise we only have generic "Something that worked before does not work anymore" task summaries for lots of bug report that don't allow distinguishing. It's not "wmf software".

Ineuw added a comment.Mar 24 2019, 2:41 AM

Using Firefox 66.01 in Windows 10, and Firefox 66.0 in Linux Mint 19.1, as well, the latest Vivaldi-snapshot in both Windows and Linux. The problem is the same in both browsers. Also uploaded this image at Wikisource with explanation. https://en.wikisource.org/wiki/File:T219048.jpg

Aklapper renamed this task from Previously existing ProofreadPage features are ommitted in the current version of wmf software to Height of reader and footer of ProofreadPage reduced, cannot resize text fields in browser.Mar 24 2019, 1:34 PM

Both the header and footer are 2 text rows high instead of 3.

Is that a regression? Was it by default 3 lines height in the past, and did this change to 2 lines height recently?

I have no problem in Firefox 66 to grab the handle of the lower right corner frame and resize the textfield.

https://en.wikisource.org/wiki/File:T219048.jpg says "It resets after closing". I do not know what that means and it would be better to keep all text centralized in this very task. You can also add images here in Phabricator.

Ineuw added a comment.Mar 25 2019, 3:34 AM

Yes, the header was always 3 lines, before I reported T212999 or T213043 bugs. These bugs were related to the headers and footers.

As for the "handle" in the lower right corner, they are frozen in both Vivaldi and Firefox in both Windows 10 and Linux Mint 19.1, but I will also inquire from other editors at Wikisource.

By resetting after closing, I meant that stretching of the edit windows is not permanent.

Xover added a subscriber: Xover.Mar 25 2019, 5:55 AM

All three text fields resize ok vertically here (they used to resize also horizontally, but I believe that was changed deliberately a while back). Their default size appear to be two lines.

Tested on the page linked by Aklapper above with Safari 12.0.3 (14606.4.5) on macOS Mojave 10.14.3 (latest release versions of both).

Xover renamed this task from Height of reader and footer of ProofreadPage reduced, cannot resize text fields in browser to Height of header and footer of ProofreadPage reduced, cannot resize text fields in browser.Mar 25 2019, 5:55 AM
Ineuw added a comment.Mar 25 2019, 8:32 PM

@Aklapper. It works when logged out AND the header/footer rows are 3 lines!!! So, deleted all my Wikipedia related cookies, logged back in and the problem returned. Will remove my common.js & common.css and see what happens. If it's still not working, the problem might be my preferences \edit or the \gadgets.

Ineuw added a comment.Mar 25 2019, 9:17 PM

Please close this report. It is repaired.

Aklapper closed this task as Invalid.Mar 25 2019, 10:39 PM

Please share with everyone else how it is repaired.

Ineuw added a comment.Mar 27 2019, 4:18 AM

I tested it when logged out and everything worked, so I looked in both the common.js and common.css. There were copied css settings from another editor, one of which had a max-height setting for the main textarea dimensions. After removing it, everything is as it should be.

Thanks for sharing that and glad it works for you now!