Page MenuHomePhabricator

UploadWizard: EXIF DateTime takes precedence over DateTimeOriginal
Closed, ResolvedPublicBUG REPORT

Description

When UploadWizard prefills dates for uploads, EXIF DateTime takes precedence over DateTimeOriginal. It should be the other way around.

Original bug report: https://commons.wikimedia.org/wiki/Commons:Upload_Wizard_feedback#Standard_value_for_Date_work_was_created_or_first_published

Caused by https://gerrit.wikimedia.org/r/c/mediawiki/extensions/UploadWizard/+/496459/2/resources/mw.UploadWizardDetails.js#479

Event Timeline

matmarex created this task.Mar 26 2019, 9:45 PM
Restricted Application added a project: Multimedia. · View Herald TranscriptMar 26 2019, 9:45 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 499445 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/UploadWizard@master] Fix loop break using Array.some

https://gerrit.wikimedia.org/r/499445

Change 499445 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@master] Fix loop break using Array.some

https://gerrit.wikimedia.org/r/499445

N509FZ added a subscriber: N509FZ.Mar 28 2019, 4:14 PM

Screenshot of the date field problem as of 16:10, 28 March 2019 (UTC): The original photo taken at 17:07:54 (UTC+8), and the retouched photo is modified at 23:09:05 (UTC+8).

Jdforrester-WMF removed a project: Patch-For-Review.

Screenshot of the date field problem as of 16:10, 28 March 2019 (UTC): The original photo taken at 17:07:54 (UTC+8), and the retouched photo is modified at 23:09:05 (UTC+8).

Thanks for confirming. This is now fixed, and the fix will roll out to Commons next week on 2019-04-03.

Jdforrester-WMF closed this task as Resolved.Mar 28 2019, 5:52 PM
Jdforrester-WMF triaged this task as Normal priority.
matmarex renamed this task from UploadWizard: EXIF DateTime takes prececence over DateTimeOriginal to UploadWizard: EXIF DateTime takes precedence over DateTimeOriginal.Mar 28 2019, 11:47 PM
matmarex updated the task description. (Show Details)
matmarex added a subscriber: Cybularny.

T220278 implies that this is not fixed yet.

T220278 implies that this is not fixed yet.

The train still hasn't rolled out. :-(

As far I can see, it seems to be fixed, it works well with my last upload https://commons.wikimedia.org/wiki/File:Harbour_of_S%C3%A8te_and_trawler_BW.jpg , thanks you