Page MenuHomePhabricator

Captions broken
Closed, ResolvedPublic

Description

Steps to reproduce:

  • attempt to add a caption to existing file
  • once caption is added 'cancel' and 'publish' buttons do not get hidden
  • error in console jQuery.Deferred exception: self.languageSelectors[index] is undefined

Event Timeline

Cparle created this task.Mar 27 2019, 5:25 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 27 2019, 5:25 PM

Change 499553 had a related patch set uploaded (by Cparle; owner: Cparle):
[mediawiki/extensions/WikibaseMediaInfo@master] Trigger confirm when cancel button is clicked instead of in makeReadOnly()

https://gerrit.wikimedia.org/r/499553

Change 499553 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Trigger confirm when cancel button is clicked instead of in makeReadOnly()

https://gerrit.wikimedia.org/r/499553

Ha78na added a subscriber: Ha78na.Mar 27 2019, 11:20 PM

For posterity: this bug was regression caused by T219197 which had recently merged. We luckily noticed it on beta before it got any further.

Ramsey-WMF moved this task from Untriaged to Next up on the Multimedia board.Mar 28 2019, 1:22 PM
Ramsey-WMF triaged this task as High priority.
Ramsey-WMF moved this task from To Do to Verify on Production on the SDC Engineering board.

ok on test-commons

Ramsey-WMF closed this task as Resolved.Apr 23 2019, 11:32 PM
Ramsey-WMF added a subscriber: Ramsey-WMF.

no problems on production.