Page MenuHomePhabricator

Commons search is broken
Closed, ResolvedPublic

Description

Searching on Commons presently returns:

An error has occurred while searching: We could not complete your search due to a temporary problem. Please try again later.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 27 2019, 8:48 PM
Smalyshev triaged this task as Unbreak Now! priority.Mar 27 2019, 8:48 PM
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptMar 27 2019, 8:48 PM
Smalyshev updated the task description. (Show Details)Mar 27 2019, 8:49 PM

Change 499596 had a related patch set uploaded (by DCausse; owner: DCausse):
[operations/mediawiki-config@master] [cirrus] only activate wikibase entitySearch with Cirrus in WikibaseSearchSettings.php

https://gerrit.wikimedia.org/r/499596

The reason seems to be that Commons has Wikibase search enabled, but indexes are not set up for Wikibase search. Since ES6 upgrade, Elastic is more strict about fields used in indexes, so unknown Wikibase fields used against Commons index cause an error.

Change 499596 merged by jenkins-bot:
[operations/mediawiki-config@master] [cirrus] only activate wikibase entitySearch with Cirrus in WikibaseSearchSettings.php

https://gerrit.wikimedia.org/r/499596

Smalyshev assigned this task to dcausse.Mar 27 2019, 9:25 PM

Mentioned in SAL (#wikimedia-operations) [2019-03-27T21:25:55Z] <dcausse@deploy1001> Synchronized wmf-config/Wikibase.php: T219448 (duration: 00m 55s)

Root cause looks to be this one:

16:55 jforrester@deploy1001: Synchronized wmf-config/InitialiseSettings.php: T214075 SDC: Enable Wikidata federation on Commons (duration: 00m 57s)

We knew that federation on commons would break search, T218954 needed to be merged and deployed before federation can be deployed

Oh, damn. I had a vague (false) memory that that had been fixed. Sorry. Thanks for the fix.

Change 499661 had a related patch set uploaded (by EBernhardson; owner: EBernhardson):
[mediawiki/extensions/AdvancedSearch@master] Respect true/false settings in wgNamespacesToBeSearchedDefault

https://gerrit.wikimedia.org/r/499661

Smalyshev lowered the priority of this task from Unbreak Now! to High.Mar 27 2019, 9:45 PM

Change 499661 had a related patch set uploaded (by EBernhardson; owner: EBernhardson):
[mediawiki/extensions/AdvancedSearch@master] Respect true/false settings in wgNamespacesToBeSearchedDefault

https://gerrit.wikimedia.org/r/499661

Smalyshev changed the subtype of this task from "Task" to "Bug Report".Mar 28 2019, 3:26 AM

Thanks guys! Target date for seeing the fix on Beta and Test Commons?

Searching on commons is back to fixed today. T218954 is currently delayed on issues getting it through CI, there are some interactions between multiple extensions that are proving difficult to get right. No exact date, but working on it.

Jdforrester-WMF closed this task as Resolved.Mar 28 2019, 3:13 PM
Jdforrester-WMF removed a project: Patch-For-Review.

This bit was Resolved with https://tools.wmflabs.org/sal/log/AWnBC5MIA1BDhGjCfAWA at 2019-03-27 Z 21:25. The Advanced Search breakage is T219455 and the underlying proper fix is T218954; let's track those there.

mmodell changed the subtype of this task from "Bug Report" to "Production Error".Aug 28 2019, 11:07 PM