Page MenuHomePhabricator

Starting translation from Simple English Wikipedia through gray interlanguage links loads enwiki article
Closed, ResolvedPublic

Description

I wanted to start translation of Uber from Simple English to Serbian in production through gray interlanguage links, and English article was loaded.

Also, I tried finding Simple English articles which don't exist in English Wikipedia.

  • Thirumanam (TV series): Even though this article exists only in Simple English Wikipedia and not in English Wikipedia, it gets loaded with from=en&to=sr in the URL. Not really clear to me where the source content is coming from, but it differs from Simple English Wikipedia article.
  • Radha Krishn: Article fails to load with "Critical error: Content translation failed to load due to internal error" message displayed in infobar below the publish button toolbar.
  • Brown v. Board of Education II: same as above.

Event Timeline

Petar.petkovic moved this task from Needs Triage to Bugs on the ContentTranslation board.

Change 510956 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Fix starting translation through gray interlanguage link on simplewiki

https://gerrit.wikimedia.org/r/510956

Change 510956 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Fix starting translation through gray interlanguage link on simplewiki

https://gerrit.wikimedia.org/r/510956

Etonkovidova added a subscriber: Etonkovidova.

Needs to be checked after deployment. One interesting thing - the only option for translating articles from Simple English wiki through grey links is to translate them from English. Maybe the logic behind it was that it's preferable to translate from full-content English article rather than from Simple English adjusted content?

Special:ContentTranslation correctly identifies translating from Simple English to another language.

The screenshot below illustrate two issues (@Petar.petkovic - could those be some intended limitations or a bug that is fixed by this task?):

  • Simple English is always present as a grey link - it says that an article does not exist in Simple English which is not correct
  • When another lang grey link is clicked, the dialog box offers to translate an article from English wiki not from Simple English wiki.


Thirumanam (TV series) presents a special case since the article exists only in Simple English not in English wikipedia.
It offers to translate from English but fails to load non-existing article to ContentTranslation:


The root of the problem is that Simple Wikipedia defines content language as English (with 'en' language code) and we use content language code for from parameter when starting translation using CX. So, all translations from Simple Wikipedia through gray interlanguage links are actually started from English Wikipedia. Furthermore, 'en' being used for language code is the likely cause behind showing "Translate from English" instead of "Translate from Simple English" when you click on Simple English gray interlanguage link. Also, sometimes article exists on Simple Wikipedia, but not on English Wikipedia, which causes errors when starting translations.

Simple English being always present as a grey link is not known to me and may be caused by some other bug.

This can now be checked in production, @Etonkovidova, @Jpita.

Jpita closed this task as Resolved.Jun 26 2019, 5:38 PM

checked in production, gray interlanguage links now open cx with simple english selected